ramips: Add support for GL-MT750
authorJohn Crispin <john@openwrt.org>
Thu, 10 Mar 2016 19:12:10 +0000 (19:12 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 10 Mar 2016 19:12:10 +0000 (19:12 +0000)
This patch adds support for GL-MT750.
GL-MT750 is powered by MT7620A and MT7610e, dual band 802.11ac, 2.4G 300Mbps and 5G 450Mbps.
It has 5 LANs, MMC interface, USB, a lot of IOs and PoE support.

SVN-Revision: 48994

target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/GL-MT750.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/mt7620/profiles/gli.mk

index 132c7cecbb86701eace3313c613f647ca679a598..6c25c86753d2443752351e814273020c54eafb32 100755 (executable)
@@ -138,7 +138,8 @@ fonera20n)
        set_wifi_led "$board:orange:wifi"
        ;;
 gl-mt300a|\
-gl-mt300n)
+gl-mt300n|\
+gl-mt750)
        set_wifi_led "$board:wlan"
        ;;
 hc5661)
index 40c24a976967917d70e02d1dac6d57401f6653fe..dc9b5b2b9445f77b7718b3bc8b1f61960fde1c61 100755 (executable)
@@ -115,6 +115,7 @@ ramips_setup_interfaces()
        f5d8235-v2|\
        gl-mt300a|\
        gl-mt300n|\
+       gl-mt750|\
        hg255d|\
        mzk-wdpr|\
        jhr-n805r|\
index fcc4b9fb0824bf126188a1a71ff827319810da42..815765a75e41b2bc6a9c02b71e062c2f1ccf4f28 100755 (executable)
@@ -181,6 +181,9 @@ ramips_board_detect() {
        *"GL-MT300N")
                name="gl-mt300n"
                ;;
+       *"GL-MT750")
+               name="gl-mt750"
+               ;;
        *"HC5661")
                name="hc5661"
                ;;
index 87278317bb7d69c26b5e956f8f0c3842e672ae72..b1d23471d9435980f34977e4c45c7596ef5f4cd4 100755 (executable)
@@ -58,6 +58,7 @@ platform_check_image() {
        freestation5|\
        gl-mt300a|\
        gl-mt300n|\
+       gl-mt750|\
        hc5*61|\
        hg255d|\
        hlk-rm04|\
diff --git a/target/linux/ramips/dts/GL-MT750.dts b/target/linux/ramips/dts/GL-MT750.dts
new file mode 100644 (file)
index 0000000..a36ae5e
--- /dev/null
@@ -0,0 +1,159 @@
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+/ {
+       compatible = "GL-MT750", "ralink,mt7620a-soc";
+       model = "GL-MT750";
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       palmbus@10000000 {
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+
+               gpio1: gpio@638 {
+                       status = "okay";
+               };
+
+               gpio2: gpio@660 {
+                       status = "okay";
+               };
+               
+               gpio3: gpio@688 {
+                     status = "okay";
+                };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "w25q128";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "w25q128";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xf80000>;
+                               };
+
+                               partition@ff0000 {
+                                       label = "art";
+                                       reg = <0xff0000 0x10000>;
+                               };
+                       };
+               };
+       };
+
+       sdhci@10130000 {
+               status = "okay";
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       ethernet@10100000 {
+               pinctrl-names = "default";
+               pinctrl-0 = <&ephy_pins>;
+               mtd-mac-address = <&factory 0x4000>;
+               ralink,port-map = "llllw";
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       pcie@10140000 {
+               status = "okay";
+
+               pcie-bridge {
+                       mt76@0,0 {
+                               reg = <0x0000 0 0 0 0>;
+                               device_type = "pci";
+                               mediatek,mtd-eeprom = <&factory 0x8000>;
+                               mediatek,2ghz = <0>;
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "wled","ephy","uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               wan {
+                       label = "gl-mt750:wan";
+                       gpios = <&gpio2 0 1>;
+               };
+
+               lan {
+                       label = "gl-mt750:lan";
+                       gpios = <&gpio2 1 1>;
+               };
+
+               wlan {
+                       label = "gl-mt750:wlan";
+                       gpios = <&gpio3 0 1>;
+               };
+
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 13 1>;
+                       linux,code = <0x198>;
+               };
+
+               BTN_0 {
+                       label = "BTN_0";
+                       gpios = <&gpio2 2 1>;
+                       linux,code = <0x100>;
+               };
+
+           BTN_1 {
+                       label = "BTN_1";
+                       gpios = <&gpio2 3 1>;
+                       linux,code = <0x101>;
+               };
+       };
+};
index 4a2d60767f5cc7fa200a298db72514748ede1ae7..bc42d148ad8a89e18082907b49ca9083f412d185 100644 (file)
@@ -995,6 +995,7 @@ Image/Build/Profile/WT3020=$(call BuildFirmware/PorayDualSize/$(1),$(1),wt3020,W
 Image/Build/Profile/MIWIFI-MINI=$(call BuildFirmware/Default16M/$(1),$(1),miwifi-mini,MIWIFI-MINI)
 Image/Build/Profile/GL-MT300A=$(call BuildFirmware/Default16M/$(1),$(1),gl-mt300a,GL-MT300A)
 Image/Build/Profile/GL-MT300N=$(call BuildFirmware/Default16M/$(1),$(1),gl-mt300n,GL-MT300N)
+Image/Build/Profile/GL-MT750=$(call BuildFirmware/Default16M/$(1),$(1),gl-mt750,GL-MT750)
 Image/Build/Profile/ZTE-Q7=$(call BuildFirmware/Default8M/$(1),$(1),zte-q7,ZTE-Q7)
 Image/Build/Profile/YOUKU-YK1=$(call BuildFirmware/Default16M/$(1),$(1),youku-yk1,YOUKU-YK1)
 Image/Build/Profile/ZBT-WA05=$(call BuildFirmware/Default8M/$(1),$(1),zbt-wa05,ZBT-WA05)
@@ -1040,6 +1041,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/MIWIFI-MINI,$(1))
        $(call Image/Build/Profile/GL-MT300A,$(1))
        $(call Image/Build/Profile/GL-MT300N,$(1))
+       $(call Image/Build/Profile/GL-MT750,$(1))
        $(call Image/Build/Profile/ZTE-Q7,$(1))
        $(call Image/Build/Profile/YOUKU-YK1,$(1))
        $(call Image/Build/Profile/ZBT-WA05,$(1))
index 6473ff07e5d053732cd9ee23b0aa4ed5e549dc66..ae220d5adfd611f9737b37624427099567d8ea70 100644 (file)
@@ -25,3 +25,12 @@ define Profile/GL-MT300N/Description
 endef
 $(eval $(call Profile,GL-MT300N))
 
+define Profile/GL-MT750
+       NAME:=GL-MT750
+       PACKAGES:=kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-mt7610e
+endef
+
+define Profile/GL-MT750/Description
+       Support for gl-mt750 Router
+endef
+$(eval $(call Profile,GL-MT750))