add function names to quilt-generated patch files to make patches more readable
authorFelix Fietkau <nbd@openwrt.org>
Fri, 10 Oct 2008 01:44:55 +0000 (01:44 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 10 Oct 2008 01:44:55 +0000 (01:44 +0000)
SVN-Revision: 12938

include/quilt.mk

index 07bab8b440c3e8090ab9a811aeb4dd24a48df38d..70bc84e4cce6a56f4f6ca70becb30371ddc881a3 100644 (file)
@@ -148,7 +148,7 @@ define Build/Quilt
   refresh: quilt-check
        @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null
        @cd $(PKG_BUILD_DIR); while quilt next 2>/dev/null >/dev/null && quilt push; do \
   refresh: quilt-check
        @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null
        @cd $(PKG_BUILD_DIR); while quilt next 2>/dev/null >/dev/null && quilt push; do \
-               quilt refresh -p ab --no-index --quiltrc=/dev/null --no-timestamps; \
+               QUILT_DIFF_OPTS="-p" quilt refresh -p ab --no-index --quiltrc=/dev/null --no-timestamps; \
        done; ! quilt next 2>/dev/null >/dev/null
        $(Quilt/Refresh)
        
        done; ! quilt next 2>/dev/null >/dev/null
        $(Quilt/Refresh)