fortify-headers: update to 0.7
authorSteven Barth <cyrus@openwrt.org>
Fri, 24 Jul 2015 13:51:45 +0000 (13:51 +0000)
committerSteven Barth <cyrus@openwrt.org>
Fri, 24 Jul 2015 13:51:45 +0000 (13:51 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 46480

toolchain/fortify-headers/Makefile
toolchain/fortify-headers/patches/100-fix-getgroups.patch [deleted file]
toolchain/fortify-headers/patches/101-fix-pedantic.patch [deleted file]

index b9cefe593573b3a809b13a8ca0c9f3ee8967fcce..8d952c54cf550ecb599b28671afab1fd2c07f63d 100644 (file)
@@ -8,12 +8,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=fortify-headers
-PKG_VERSION:=0.6
+PKG_VERSION:=0.7
 PKG_RELEASE=1
 
 PKG_SOURCE_URL:=http://dl.2f30.org/releases
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=d85072939ec02a40af282fe3febc6c18
+PKG_MD5SUM:=3f7c36daa0be000987e8ad8c0a202b42
 
 include $(INCLUDE_DIR)/toolchain-build.mk
 
diff --git a/toolchain/fortify-headers/patches/100-fix-getgroups.patch b/toolchain/fortify-headers/patches/100-fix-getgroups.patch
deleted file mode 100644 (file)
index 988deb5..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-From 1f9848efc8a329cb9a13323cbb94b353d39802c1 Mon Sep 17 00:00:00 2001
-From: Steven Barth <steven@midlink.org>
-Date: Mon, 22 Jun 2015 14:36:16 +0200
-Subject: [PATCH] unistd: fix signed / unsigned comparison in getgroups
-
-Signed-off-by: Steven Barth <steven@midlink.org>
----
- include/unistd.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/include/unistd.h b/include/unistd.h
-index 45304e1..5274e22 100644
---- a/include/unistd.h
-+++ b/include/unistd.h
-@@ -71,7 +71,7 @@ _FORTIFY_FN(getgroups) int getgroups(int __l, gid_t *__s)
- {
-       size_t __b = __builtin_object_size(__s, 0);
--      if (__l > __b / sizeof(gid_t))
-+      if (__l < 0 || (size_t)__l > __b / sizeof(gid_t))
-               __builtin_trap();
-       return __orig_getgroups(__l, __s);
- }
--- 
-2.1.4
-
diff --git a/toolchain/fortify-headers/patches/101-fix-pedantic.patch b/toolchain/fortify-headers/patches/101-fix-pedantic.patch
deleted file mode 100644 (file)
index fd36302..0000000
+++ /dev/null
@@ -1,122 +0,0 @@
-From 631ada7ea21c9a8f389ce0448ae05e0881264fec Mon Sep 17 00:00:00 2001
-From: Steven Barth <steven@midlink.org>
-Date: Wed, 24 Jun 2015 20:13:37 +0200
-Subject: [PATCH] Add __extension__ mark to include_next to silence -pedantic
-
-Signed-off-by: Steven Barth <steven@midlink.org>
----
- include/poll.h       | 1 +
- include/stdio.h      | 1 +
- include/stdlib.h     | 2 ++
- include/string.h     | 1 +
- include/sys/select.h | 1 +
- include/sys/socket.h | 1 +
- include/unistd.h     | 1 +
- include/wchar.h      | 2 ++
- 8 files changed, 10 insertions(+)
-
-diff --git a/include/poll.h b/include/poll.h
-index d9b602c..9e1d99a 100644
---- a/include/poll.h
-+++ b/include/poll.h
-@@ -16,6 +16,7 @@
- #ifndef _FORTIFY_POLL_H
- #define _FORTIFY_POLL_H
-+__extension__
- #include_next <poll.h>
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/stdio.h b/include/stdio.h
-index 996c661..1b76f82 100644
---- a/include/stdio.h
-+++ b/include/stdio.h
-@@ -16,6 +16,7 @@
- #ifndef _FORTIFY_STDIO_H
- #define _FORTIFY_STDIO_H
-+__extension__
- #include_next <stdio.h>
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/stdlib.h b/include/stdlib.h
-index 2b67235..f89341f 100644
---- a/include/stdlib.h
-+++ b/include/stdlib.h
-@@ -16,9 +16,11 @@
- #ifndef _FORTIFY_STDLIB_H
- #define _FORTIFY_STDLIB_H
-+__extension__
- #include_next <stdlib.h>
- #if defined(_XOPEN_SOURCE) || defined(_GNU_SOURCE) || defined(_BSD_SOURCE)
-+__extension__
- #include_next <limits.h>
- #endif
-diff --git a/include/string.h b/include/string.h
-index 98bfea1..a4072d6 100644
---- a/include/string.h
-+++ b/include/string.h
-@@ -16,6 +16,7 @@
- #ifndef _FORTIFY_STRING_H
- #define _FORTIFY_STRING_H
-+__extension__
- #include_next <string.h>
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/sys/select.h b/include/sys/select.h
-index db6135d..7f768f4 100644
---- a/include/sys/select.h
-+++ b/include/sys/select.h
-@@ -16,6 +16,7 @@
- #ifndef _FORTIFY_SYS_SELECT_H
- #define _FORTIFY_SYS_SELECT_H
-+__extension__
- #include_next <sys/select.h>
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/sys/socket.h b/include/sys/socket.h
-index e68e21c..9454951 100644
---- a/include/sys/socket.h
-+++ b/include/sys/socket.h
-@@ -16,6 +16,7 @@
- #ifndef _FORTIFY_SYS_SOCKET_H
- #define _FORTIFY_SYS_SOCKET_H
-+__extension__
- #include_next <sys/socket.h>
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/unistd.h b/include/unistd.h
-index 5274e22..5fa3b44 100644
---- a/include/unistd.h
-+++ b/include/unistd.h
-@@ -16,6 +16,7 @@
- #ifndef _FORTIFY_UNISTD_H
- #define _FORTIFY_UNISTD_H
-+__extension__
- #include_next <unistd.h>
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
-diff --git a/include/wchar.h b/include/wchar.h
-index 6fa86f2..0d4abfa 100644
---- a/include/wchar.h
-+++ b/include/wchar.h
-@@ -16,7 +16,9 @@
- #ifndef _FORTIFY_WCHAR_H
- #define _FORTIFY_WCHAR_H
-+__extension__
- #include_next <stdlib.h>
-+__extension__
- #include_next <wchar.h>
- #if defined(_FORTIFY_SOURCE) && _FORTIFY_SOURCE > 0 && defined(__OPTIMIZE__) && __OPTIMIZE__ > 0
--- 
-2.1.4
-