toolchain: stop generating broken symlink in TOOLCHAIN_DIR/lib
authorLuka Perkov <luka@openwrt.org>
Thu, 28 Mar 2013 12:16:39 +0000 (12:16 +0000)
committerLuka Perkov <luka@openwrt.org>
Thu, 28 Mar 2013 12:16:39 +0000 (12:16 +0000)
It turns out that the symlink may exists already by the time the toolchain
Makefile gets an opportunity to run. While we asked to replace the target, ln
doesn't do so until after dereferencing the existing symlink. This results in
an unintended symlink that refers to itself. Instead, create the link without
dereferencing any symlinks by using the -n option.

Signed-off-by: John Szakmeister <john@szakmeister.net>
SVN-Revision: 36140

toolchain/Makefile

index bdfb29ec1707ad54a0ddd820c7e64dff31c28981..763381a838cd4525bbcce6134341076e82b2ba0c 100644 (file)
@@ -63,7 +63,7 @@ ifneq ($(ARCH),)
                $(if $(QUIET),,set -x;) \
                mkdir -p "$$dir"; \
                cd "$$dir"; \
-               ln -sf lib lib64; \
+               ln -nsf lib lib64; \
                mkdir -p stamp lib usr/include usr/lib ; \
        ); done
        @grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@