mt76: sync with version 878456caf60d from master
authorFelix Fietkau <nbd@nbd.name>
Thu, 12 Oct 2017 09:49:00 +0000 (11:49 +0200)
committerFelix Fietkau <nbd@nbd.name>
Fri, 13 Oct 2017 09:56:25 +0000 (11:56 +0200)
Backport required DT changes from commit dabdd123c90c.
Significantly improves stability and performance for MT76x2 and MT7603

Signed-off-by: Felix Fietkau <nbd@nbd.name>
31 files changed:
package/kernel/mt76/Makefile
target/linux/ramips/dts/ArcherC20i.dts
target/linux/ramips/dts/ArcherC50.dts
target/linux/ramips/dts/ArcherMR200.dts
target/linux/ramips/dts/DIR-860L-B1.dts
target/linux/ramips/dts/FIREWRT.dts
target/linux/ramips/dts/GL-MT750.dts
target/linux/ramips/dts/MAC1200RV2.dts
target/linux/ramips/dts/MIWIFI-MINI.dts
target/linux/ramips/dts/MZK-750DHP.dts
target/linux/ramips/dts/MZK-EX750NP.dts
target/linux/ramips/dts/Newifi-D1.dts
target/linux/ramips/dts/PBR-M1.dts
target/linux/ramips/dts/PSG1208.dts
target/linux/ramips/dts/PSG1218.dts
target/linux/ramips/dts/RE6500.dts
target/linux/ramips/dts/SAP-G3200U3.dts
target/linux/ramips/dts/SK-WB8.dts
target/linux/ramips/dts/W2914NSV2.dtsi
target/linux/ramips/dts/WF-2881.dts
target/linux/ramips/dts/WHR-1166D.dts
target/linux/ramips/dts/WITI.dts
target/linux/ramips/dts/WL-WN575A3.dts
target/linux/ramips/dts/WNDR3700V5.dts
target/linux/ramips/dts/WSR-1166.dts
target/linux/ramips/dts/WSR-600.dts
target/linux/ramips/dts/Y1.dtsi
target/linux/ramips/dts/ZBT-APE522II.dts
target/linux/ramips/dts/ZBT-WG2626.dts
target/linux/ramips/dts/ZBT-WG3526.dtsi
target/linux/ramips/dts/mt7628an.dtsi

index 8a6e414e10c35557b2fc6b89f80bec6c2297ee59..06b9eb07f3e35cce9b03b3635c79d4ae50f46599 100644 (file)
@@ -1,16 +1,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mt76
-PKG_RELEASE=2
+PKG_RELEASE=1
 
 PKG_LICENSE:=GPLv2
 PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/openwrt/mt76
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2017-01-31
-PKG_SOURCE_VERSION:=3c8caafc5e150db79f714b958a51cee8f242f309
-PKG_MIRROR_HASH:=c03c166466cb7ea825e52cd085511045e3847d927ba2bde2b8fb46595a3ed13a
+PKG_SOURCE_DATE:=2017-10-12
+PKG_SOURCE_VERSION:=1be430fc8ae486e61f51f76925b30d6ff64c37dd
+PKG_MIRROR_HASH:=992e3d86d493b976ec23fb4f1179a72c3e34199c6ec5a93f37069555c9b19d9c
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_BUILD_PARALLEL:=1
index b1001bfaaba041165fb794f2fb1f1eb632c4e4e7..5d0fc308c3cd14fb5d72906d8268e30df1f55e39 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&radio 32768>;
-                       mediatek,2ghz = <0>;
                };
        };
 };
index 465260b56124c7a3bb2b9ce5b236df075b909b38..c581787166c318e8a59b79445e89a1360e94db1e 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&radio 32768>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                        mtd-mac-address = <&rom 0xf100>;
                        mtd-mac-address-increment = <(-1)>;
                };
index bbbf0af3889b292b8b1f03fc0609affe8f5ea500..f41014bbf65db1bbb92333a48d5bb61dcbaa4d0a 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&radio 32768>;
-                       mediatek,2ghz = <0>;
                };
        };
 };
index 98c9d8a0bb77790cf7c3433b4116a0bd1e8aae53..cc6c32b14603fa7514417411e2cf77d3fba8285d 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&radio 0x2000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&radio 0>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                };
        };
 };
index 1871de99be9606c72fbe9422d2eb91e15e5815c2..c1509ccc552edf3931987571515ef633f65c3ee4 100644 (file)
@@ -93,7 +93,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                };
        };
 };
index 8bf96c7d35aacf7383b64fc5b98f60b0b0714ad6..ad1e3f91735d0a97f179b8190eea4d44a534754d 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
                };
        };
 };
index 45c26e1e8089ad0c06552e40935349697e9bd661..73ba493c5de76e705b568564ed2fe01b60f2e91f 100644 (file)
@@ -87,7 +87,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&art 0x1000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index 101ae8d8440e8ee54d5890fe468ca33caa841b06..45e1f2ef5f7c496ecc3ca4052292df8c4a7e4e09 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index 4107c6faacb099d6207961cc0527535b483ab0b5..dfefb0e3201f2041a7208a5230a04481aa36c225 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
                };
        };
 };
index 3aa2a57dfb07c2b60e4859e22b54b1a8b1014e91..29a11898e8dfe54755513871e6bf6a73524b4a10 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
                };
        };
 };
index 2d128ac6d2e3cc306634491aea8c298bc7db0def..89bc8515a62d2d4c6e75a3b932f7ff7a6ce7ab6d 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 };
index 9a0c713daa917a2e1205bafc6118ef3c9823aa92..7baf07499bf3c65f8be8934ea1c165676769bebf 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 };
index 6ae56f2d708990ba46fd81d61e4f9e22e3ae92f0..6680f5df2ac556e9f58ceaf5a4b67985fe5a3ece 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index 5e90d1bf1c2f1b8ea8e4fa6b4b1b5c036bfccfd9..1e53dcef3d07c50983dc0ac1278424788af2b008 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index 3fe875db1227d61a6eb12486ed6c091414d11cc4..07439fa573de163705c318b08d03f88b28a2dc60 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                };
        };
 };
index 7be6e033c7927d302c465669c95124e4cff018b3..dbaa6a31cf095a7a11965509c72bed4e96c4dfd2 100644 (file)
@@ -95,7 +95,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                };
        };
 };
index 87adc9ae1d943cd6dccfebbc1265db25ba6f45d7..f5da941031d852b67ca1c48019c2177b34102628 100644 (file)
@@ -92,7 +92,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 };
index 7b11a0f6a22ec7649e78c42397d161eb5f14b293..51ec1618408d8cb809625d1612b0bdaf93412f5b 100644 (file)
        status = "okay";
 
        pcie0 {
-               wifi@14c3,7662 {
-                       compatible = "pci14c3,7662";
+               wifi@14c3,7603 {
+                       compatible = "pci14c3,7603";
                        reg = <0x0000 0 0 0 0>;
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 
        pcie1 {
-               wifi@14c3,7603 {
-                       compatible = "pci14c3,7603";
+               wifi@14c3,7662 {
+                       compatible = "pci14c3,7662";
                        reg = <0x0000 0 0 0 0>;
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index 84a14e4e0195d2eea5cd5efe2310de40f9b48abe..80676fa896d2a67a77eb5722ff1b41dae2e970e9 100644 (file)
@@ -85,7 +85,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
@@ -94,7 +94,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                };
        };
 };
index 66fcc9b6839f67fb5d4c77bbf7f958a99ced17f2..a0eb5c0c2570824d975fc47c58ba80f2d6d176f9 100644 (file)
                        compatible = "pci0,0";
                        reg = <0x0000 0 0 0 0>;
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index de0c517d0ce63513a824bcf467b68266594009cb..91f669364de6c587f6e83adefef1fa4c7ee91b28 100644 (file)
@@ -89,7 +89,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                        mtd-mac-address = <&factory 0xe000>;
                };
        };
@@ -99,7 +99,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                        mtd-mac-address = <&factory 0xe000>;
                };
        };
index 63eff77a0819bbb29b91d6c7b6f21da0c235e811..98716beb496cc148a37fa81d3e78d79f7e1f4583 100644 (file)
@@ -77,7 +77,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index bb879a1441eac5b4f34170bb412abce89348e934..ec97ac805dd77651e3994cab17b8291e7012509d 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 };
index ab6a9a4e3f5a753e86ab705b538bbd69b868fe9c..5d5725cfdecfc6a3003ec88d368a0c4f5de45f7d 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 };
index 63206b4d613d16bc65f8f93f4aa334e4dccecc9d..3f7238cfa76fcfc2f4c9d6e90886c0bac5891c08 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 };
index 8e6133a61cf10c6cd07a7812713f3addff523282..0ac04c43c168ea92e2b4e307720ac0d40bf368f3 100644 (file)
@@ -84,7 +84,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index 5eca65f24cf59be7b13375440514ee4330bbfef1..9a8b700a50cc235b41653c3c7741c06793bf8703 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index a75ca89aa891f8ac1d7f505b389dd76f97163b24..65541a5a445cd5ccaf8a113825b3b56a85d59b6e 100644 (file)
@@ -93,7 +93,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                };
        };
 };
index e48ef3a25b039b5f2c39b52783ba23cec186adbf..582e42083920c465588f14e59e10eafe735640fb 100644 (file)
@@ -88,7 +88,6 @@
                        compatible = "pci14c3,7603";
                        reg = <0x0000 0 0 0 0>;
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 
@@ -97,7 +96,7 @@
                        compatible = "pci14c3,7662";
                        reg = <0x0000 0 0 0 0>;
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index dc3ba9e323a76b9a9c0fea8c1a715b4f8319f5ce..b64a87a493e4b1eab151c096cb3c18f00aea7798 100644 (file)
                status = "disabled";
 
                mediatek,mtd-eeprom = <&factory 0x0000>;
-               mediatek,5ghz = <0>;
        };
 };