xburst: remove hack to determine entry point
authorFelix Fietkau <nbd@nbd.name>
Fri, 13 Jan 2017 18:20:57 +0000 (19:20 +0100)
committerFelix Fietkau <nbd@nbd.name>
Fri, 13 Jan 2017 18:46:45 +0000 (19:46 +0100)
xburst has CONFIG_BOOT_RAW set, so jumping to the load address is valid

Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/xburst/image/Makefile

index 08536075065a9210dde4479e3d62b925f587cab4..ff25fbebcc4726f8d553c1be5bfeabd43b7ba214 100644 (file)
@@ -20,15 +20,10 @@ endif
 
 UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage.bin
 
-define kernel_entry
-0x$(shell $(TARGET_CROSS)nm $(1) 2>/dev/null | grep " kernel_entry" | cut -f1 -d ' ')
-endef
-
-
 define MkImageGzip
        gzip -9n -c $(1) > $(1).gz
        mkimage -A mips -O linux -T kernel -a 0x80010000 -C gzip \
-               -e $(call kernel_entry,$(KDIR)/vmlinux.debug) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -e 0x80010000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
                -d $(1).gz $(2)
 endef