binutils: link libbfd and libopcodes dynamically again
authorJonas Gorski <jogo@openwrt.org>
Sat, 30 Aug 2014 11:02:22 +0000 (11:02 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sat, 30 Aug 2014 11:02:22 +0000 (11:02 +0000)
Build libbfd and libopcodes as shared libraries, else they get linked
statically into every binary, increasing each binary size by ~650kB.

Reduces binutils package size to old expected values.

Fixes #17060.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42337

package/devel/binutils/Makefile

index a88b5d17244f0f09fd34eebe6b2af72fe3a4a629..e8d45d2d8bbe92bb20f0efb547d3069d28c5e349 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=binutils
 PKG_VERSION:=2.24
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=@GNU/binutils
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -48,6 +48,7 @@ endef
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
+       --enable-shared \
        --enable-install-libiberty \
        --enable-install-libbfd
 
@@ -67,6 +68,8 @@ endef
 define Package/objdump/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/objdump $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libopcodes*.so $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbfd*.so $(1)/usr/lib/
 endef
 
 define Package/binutils/install