ar71xx: rename AP136 to AP136-010
authorGabor Juhos <juhosg@openwrt.org>
Wed, 26 Dec 2012 09:50:31 +0000 (09:50 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 26 Dec 2012 09:50:31 +0000 (09:50 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34883

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/uci-defaults/network
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/patches-3.6/609-MIPS-ath79-ap136-fixes.patch
target/linux/ar71xx/patches-3.6/610-MIPS-ath79-openwrt-machines.patch

index 0b6e8f8e03b79c126e3722f5997ecb32373794b6..bfe1416c85fd0a4e145417cf72fb00d962abb774 100755 (executable)
@@ -36,7 +36,7 @@ get_status_led() {
        all0305)
                status_led="eap7660d:green:ds4"
                ;;
-       ap136)
+       ap136-010)
                status_led="ap136:green:status"
                ;;
        ap81)
index d6b60650c7c482b52b565aa5c490ac0290af73b8..fe0ce03d9cd53f2151396c1d39a3eb93b1e28de8 100755 (executable)
@@ -22,7 +22,7 @@ ubnt-unifi-outdoor)
        ucidef_set_interface_lan "eth0 eth1"
        ;;
 
-ap136)
+ap136-010)
        ucidef_set_interfaces_lan_wan "eth0" "eth1"
        ucidef_add_switch "switch0" "1" "1"
        ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 4"
index 7327166fba8ae4ae81c957cd7b6880cd9abdf5f4..d7888638aee351e4d04db8c5745c264e16a39a14 100755 (executable)
@@ -174,8 +174,8 @@ ar71xx_board_detect() {
        *AP121-MINI)
                name="ap121-mini"
                ;;
-       *"AP136 reference board")
-               name="ap136"
+       *"AP136-010 reference board")
+               name="ap136-010"
                ;;
        *AP81)
                name="ap81"
index 3d9e02416809df1e77e2a5635934f89ec74bf8af..1cfc6e3cfbc770af3ed69f3fccc234e9b6ff9844 100755 (executable)
@@ -88,7 +88,7 @@ platform_check_image() {
        ap113 | \
        ap121 | \
        ap121-mini | \
-       ap136 | \
+       ap136-010 | \
        ap96 | \
        db120 | \
        hornet-ub | \
index 742458ebb5f0fe2ac142a659ecbf0d26bab71a3c..c4cf7545e48a236d9d16efa786b9c46e63af77fc 100644 (file)
@@ -820,7 +820,7 @@ $(eval $(call SingleProfile,AthLzma,$(fs_64k),AP113,ap113,AP113,ttyS0,115200,$$(
 $(eval $(call SingleProfile,AthLzma,$(fs_64k),AP121_2M,ap121-2M,AP121,ttyATH0,115200,$$(ap121_mtdlayout_2M),720896,1245184,RKuImage))
 $(eval $(call SingleProfile,AthLzma,$(fs_64k),AP121_4M,ap121-4M,AP121,ttyATH0,115200,$$(ap121_mtdlayout_4M),917504,2818048,RKuImage))
 $(eval $(call SingleProfile,AthLzma,$(fs_64k),AP121MINI,ap121-mini,AP121-MINI,ttyATH0,115200,$$(ap121_mtdlayout_4M),917504,2818048,RKuImage))
-$(eval $(call SingleProfile,AthLzma,$(fs_64k),AP136,ap136,AP136,ttyS0,115200,$$(ap136_mtdlayout),1441792,6488064,RKuImage))
+$(eval $(call SingleProfile,AthLzma,$(fs_64k),AP136_010,ap136-010,AP136-010,ttyS0,115200,$$(ap136_mtdlayout),1441792,6488064,RKuImage))
 $(eval $(call SingleProfile,AthLzma,$(fs_64k),CAP4200AG,cap4200ag,CAP4200AG,ttyS0,115200,$$(cap4200ag_mtdlayout),1572864,12386304,KRuImage))
 $(eval $(call SingleProfile,AthLzma,$(fs_64k),DB120,db120,DB120,ttyS0,115200,$$(db120_mtdlayout),1441792,6488064,RKuImage))
 $(eval $(call SingleProfile,AthLzma,$(fs_64k),EWDORINAP,ew-dorin,EW-DORIN,ttyATH0,115200,$$(ew-dorin_mtdlayout_4M),1048576,2752512,KRuImage))
@@ -948,6 +948,7 @@ $(eval $(call SingleProfile,Zcomax,$(fs_64k),ZCN1523H516,zcn-1523h-5-16,ZCN-1523
 $(eval $(call SingleProfile,ZyXEL,$(fs_64k),NBG_460N_550N_550NH,nbg460n_550n_550nh,NBG460N,ttyS0,115200,NBG-460N))
 
 $(eval $(call MultiProfile,AP121,AP121_2M AP121_4M))
+$(eval $(call MultiProfile,AP136,AP136_010))
 $(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT))
 $(eval $(call MultiProfile,OPENMESH,OM2P MR600))
 $(eval $(call MultiProfile,TEW652BRP,TEW652BRP_FW TEW652BRP_RECOVERY))
index 9b887cbf30b45f7a1f0e5723b7e2c1e2462b7b90..d2852fb7cb8a5963ee0c3291e0ff3d8f5ba95a3c 100644 (file)
@@ -56,7 +56,7 @@
  
  static struct gpio_led ap136_leds_gpio[] __initdata = {
        {
-@@ -98,63 +104,103 @@ static struct gpio_keys_button ap136_gpi
+@@ -98,64 +104,105 @@ static struct gpio_keys_button ap136_gpi
        },
  };
  
 +      ath79_register_eth(1);
  }
  
- MIPS_MACHINE(ATH79_MACH_AP136, "AP136", "Atheros AP136 reference board",
+-MIPS_MACHINE(ATH79_MACH_AP136, "AP136", "Atheros AP136 reference board",
++MIPS_MACHINE(ATH79_MACH_AP136_010, "AP136-010",
++           "Atheros AP136-010 reference board",
+            ap136_setup);
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -18,7 +18,7 @@ enum ath79_mach_type {
+       ATH79_MACH_GENERIC = 0,
+       ATH79_MACH_AP121,               /* Atheros AP121 reference board */
+       ATH79_MACH_AP121_MINI,          /* Atheros AP121-MINI reference board */
+-      ATH79_MACH_AP136,               /* Atheros AP136 reference board */
++      ATH79_MACH_AP136_010,           /* Atheros AP136-010 reference board */
+       ATH79_MACH_AP81,                /* Atheros AP81 reference board */
+       ATH79_MACH_DB120,               /* Atheros DB120 reference board */
+       ATH79_MACH_PB44,                /* Atheros PB44 reference board */
index 1425f7151e7bd7c40c9f35e5f419866d6bff3372..21cfc76550bca133c45961d8e385428a050e98ec 100644 (file)
@@ -12,7 +12,7 @@
 +      ATH79_MACH_AP113,               /* Atheros AP113 reference board */
        ATH79_MACH_AP121,               /* Atheros AP121 reference board */
        ATH79_MACH_AP121_MINI,          /* Atheros AP121-MINI reference board */
-       ATH79_MACH_AP136,               /* Atheros AP136 reference board */
+       ATH79_MACH_AP136_010,           /* Atheros AP136-010 reference board */
        ATH79_MACH_AP81,                /* Atheros AP81 reference board */
 +      ATH79_MACH_AP83,                /* Atheros AP83 */
 +      ATH79_MACH_AP96,                /* Atheros AP96 */