target.mk: check that CPU_TYPE has known CPU_CFLAGS mapping
authorPhilip Prindeville <philipp@redfish-solutions.com>
Wed, 4 Jan 2017 01:15:15 +0000 (18:15 -0700)
committerJo-Philipp Wich <jo@mein.io>
Wed, 13 Dec 2017 14:00:21 +0000 (15:00 +0100)
If someone creates a target and indicates a CPU_TYPE, but there's
no corresponding support for that CPU_TYPE's flags in include/target.mk
then that should probably be indicated rather than silently ignored.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
(cherry picked from commit d3bc11857af788e185e8a3ece26ce40757cf3965)

include/target.mk

index 30994485e183c16d052614aa00b5046e58e5e9ae..169ce6247a55b734d2aa462516dc18461fdad698 100644 (file)
@@ -218,6 +218,11 @@ ifeq ($(DUMP),1)
     CPU_CFLAGS_arc700 = -marc700
     CPU_CFLAGS_archs = -marchs
   endif
+  ifneq ($(CPU_TYPE),)
+    ifndef CPU_CFLAGS_$(CPU_TYPE)
+      $(warning CPU_TYPE "$(CPU_TYPE)" doesn't correspond to a known type)
+    endif
+  endif
   DEFAULT_CFLAGS=$(strip $(CPU_CFLAGS) $(CPU_CFLAGS_$(CPU_TYPE)) $(CPU_CFLAGS_$(CPU_SUBTYPE)))
 
   ifneq ($(BOARD),)