git-kernel: $(SUBDIR) should always be $(LINUX_VERSION)
authorMirko Vogt <mirko-openwrt@nanl.de>
Wed, 18 Jan 2017 13:36:45 +0000 (14:36 +0100)
committerFelix Fietkau <nbd@nbd.name>
Wed, 18 Jan 2017 20:03:26 +0000 (21:03 +0100)
Before SUBDIR was set to $(PATCHVER) which may
or may not include the minor version number of
the linux kernel version. Usually it doesn't.

So the git-clone'd linux kernel was packed without
the minor version number taken into account, which
broke further processing, as it expected the
extracted dir being named linux-$(LINUX_VERSION)
(=with minor version) rather than linux-$(PATCHVER)
(=without minor version).

Changing SUBDIR to $(LINUX_VERSION) creates
consistent behaviour here.

Signed-off-by: Mirko Vogt <mirko-openwrt@nanl.de>
include/kernel-build.mk

index 2bf47b17e448e67d483e6ef2d5d2a96c9c054514..32da94babc75268756120b9d9b63373a8cf44b39 100644 (file)
@@ -60,7 +60,7 @@ define Download/git-kernel
   PROTO:=git
   VERSION:=$(CONFIG_KERNEL_GIT_BRANCH)
   FILE:=$(LINUX_SOURCE)
-  SUBDIR:=linux-$(KERNEL_PATCHVER)
+  SUBDIR:=linux-$(LINUX_VERSION)
   OPTS:=$(KERNEL_GIT_OPTS)
 endef