package: remove .git files from images
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Apr 2016 12:50:30 +0000 (12:50 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Apr 2016 12:50:30 +0000 (12:50 +0000)
If you have your ./files/ directory stored in a git repository,
the .git will be included into images using precious space.
This patch removes .git directories before packing images.

Signed-off-by: Joerg Jungermann <jj@borkum.net>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 49180

package/Makefile

index c97e2c18d1484a3f35c2d6c625e751c630431389..e0bd75ba7f6bfc72e6740552b52cce438c6cbee9 100644 (file)
@@ -123,6 +123,7 @@ $(curdir)/install: $(TMP_DIR)/.build $(curdir)/system/opkg/host/install
        $(if $(SOURCE_DATE_EPOCH),sed -i "s/Installed-Time: .*/Installed-Time: $(SOURCE_DATE_EPOCH)/" $(TARGET_DIR)/usr/lib/opkg/status)
        @-find $(TARGET_DIR) -name CVS   | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name .svn  | $(XARGS) rm -rf
+       @-find $(TARGET_DIR) -name .git  | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
        rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.postinst*
        rm -f $(TARGET_DIR)/usr/lib/opkg/info/*.prerm*