upgrade to 3.2, disable ppp by default until we figure out why ppp_generic breaks...
authorImre Kaloz <kaloz@openwrt.org>
Mon, 19 Mar 2012 11:27:34 +0000 (11:27 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 19 Mar 2012 11:27:34 +0000 (11:27 +0000)
SVN-Revision: 31020

target/linux/ppc44x/Makefile
target/linux/ppc44x/config-default

index ed5718764a3e446eeebad706cf5868ea12b95e80..629eab0361928e12ad2fc61011392a8a8ec8587b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -13,10 +13,12 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.18
+LINUX_VERSION:=3.2.11
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES))
+
 define Target/Description
        Build firmware images for AMCC/IBM PPC44x based boards.
 endef
index bec21b58250e3432bb3ce168a40d6eebfe64fdb5..ffbbc0a8e404e0380a19414c72043bd27f4c3fa4 100644 (file)
@@ -77,6 +77,17 @@ CONFIG_HW_RANDOM=y
 # CONFIG_HZ_100 is not set
 CONFIG_HZ=250
 CONFIG_HZ_250=y
+# CONFIG_IBM_EMAC_DEBUG is not set
+CONFIG_IBM_EMAC_EMAC4=y
+CONFIG_IBM_EMAC_POLL_WEIGHT=32
+CONFIG_IBM_EMAC_RGMII=y
+CONFIG_IBM_EMAC_RXB=128
+CONFIG_IBM_EMAC_RX_COPY_THRESHOLD=256
+CONFIG_IBM_EMAC_RX_SKB_HEADROOM=0
+CONFIG_IBM_EMAC_TAH=y
+CONFIG_IBM_EMAC_TXB=128
+CONFIG_IBM_EMAC=y
+CONFIG_IBM_EMAC_ZMII=y
 # CONFIG_IBM_NEW_EMAC_DEBUG is not set
 CONFIG_IBM_NEW_EMAC_EMAC4=y
 CONFIG_IBM_NEW_EMAC_POLL_WEIGHT=32