ramips: mt7620: add DIR-810L's mt7610e 5 GHz radio
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>
Wed, 24 Oct 2018 16:07:43 +0000 (18:07 +0200)
committerMathias Kresin <dev@kresin.me>
Wed, 28 Nov 2018 00:11:38 +0000 (01:11 +0100)
The 5 GHz radio of this device uses an mt7610e pci-e chip, which has
been recently added support.

Tested on the actual device as AP and client, TCP throughput ~90 Mbps
U/D.

Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net>
target/linux/ramips/dts/DIR-810L.dts
target/linux/ramips/image/mt7620.mk

index b38290af531cf88f542b84521608a24fd16db2c4..c6d437820d7a6e95780d55ca5ef501aab55f04fe 100644 (file)
 &wmac {
        ralink,mtd-eeprom = <&factory 0>;
 };
+
+&pcie0 {
+       wifi@0,0 {
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
index bf04a75ea16554e059fd094bb0f557fe36a3c0ef..a7aeaf130cc96db1f4ac4fa8cfdc26e4054a4050 100644 (file)
@@ -154,8 +154,9 @@ TARGET_DEVICES += dch-m225
 
 define Device/dir-810l
   DTS := DIR-810L
-  IMAGE_SIZE := 6720k
+  DEVICE_PACKAGES := kmod-mt76x0e
   DEVICE_TITLE := D-Link DIR-810L
+  IMAGE_SIZE := 6720k
 endef
 TARGET_DEVICES += dir-810l