eglibc: add support for 2.14
authorFlorian Fainelli <florian@openwrt.org>
Thu, 7 Jul 2011 09:42:47 +0000 (09:42 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 7 Jul 2011 09:42:47 +0000 (09:42 +0000)
SVN-Revision: 27510

toolchain/eglibc/Config.in
toolchain/eglibc/Config.version
toolchain/eglibc/Makefile

index fb2b982b18d3625cd5369a6aa088f9da7b93c367..8d84f5af209672082a2a02f6042c1aeedca25250 100644 (file)
@@ -13,6 +13,10 @@ choice
                bool "eglibc 2.13"
                depends !GCC_VERSION_LLVM
 
+       config EGLIBC_VERSION_2_14
+               bool "eglibc 2.14"
+               depends !GCC_VERSION_LLVM
+
        config EGLIBC_VERSION_TRUNK
                bool "eglibc trunk"
 
@@ -24,6 +28,7 @@ config EGLIBC_REVISION
        depends on TOOLCHAINOPTS && USE_EGLIBC
        default "10495" if EGLIBC_VERSION_2_12
        default "13055" if EGLIBC_VERSION_2_13
+       default "14284" if EGLIBC_VERSION_2_14
        default "HEAD"  if EGLIBC_VERSION_TRUNK
        default ""
 
index 3a81ded449bed84bdf62b7b4040710243346d5f4..6b67cdda378a19631501b6dc925f556fc06f63c6 100644 (file)
@@ -3,4 +3,5 @@ config EGLIBC_VERSION
        depends on USE_EGLIBC
        default "2.12"   if EGLIBC_VERSION_2_12
        default "2.13"   if EGLIBC_VERSION_2_13
+       default "2.14"   if EGLIBC_VERSION_2_14
        default "trunk"
index 985c34bbdac2f482d1b1e482ce7cfdba10af5e0d..7d964bacfd586e3b9276ba0676ede70327eec5b9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -21,6 +21,9 @@ endif
 ifneq ($(CONFIG_EGLIBC_VERSION_2_13),)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_13
 endif
+ifneq ($(CONFIG_EGLIBC_VERSION_2_14),)
+  PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_14
+endif
 ifneq ($(CONFIG_EGLIBC_VERSION_TRUNK),)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/trunk
 endif