add missing m4 dir
authorRalph Hempel <ralph.hempel@lantiq.com>
Sun, 22 Mar 2009 18:27:13 +0000 (18:27 +0000)
committerRalph Hempel <ralph.hempel@lantiq.com>
Sun, 22 Mar 2009 18:27:13 +0000 (18:27 +0000)
SVN-Revision: 14971

tools/m4/Makefile [new file with mode: 0644]

diff --git a/tools/m4/Makefile b/tools/m4/Makefile
new file mode 100644 (file)
index 0000000..20b86ff
--- /dev/null
@@ -0,0 +1,33 @@
+# 
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=m4
+PKG_VERSION:=1.4.5
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR)
+endef
+
+define Host/Install
+       $(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+define Host/Clean
+       $(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       $(MAKE) -C $(HOST_BUILD_DIR) clean
+       $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))