update libtool from version 1.5.26 to version 2.4, this includes libltdl (to v7)...
authorMirko Vogt <mirko@openwrt.org>
Fri, 3 Dec 2010 11:56:47 +0000 (11:56 +0000)
committerMirko Vogt <mirko@openwrt.org>
Fri, 3 Dec 2010 11:56:47 +0000 (11:56 +0000)
SVN-Revision: 24224

package/libtool/Makefile
package/libtool/patches/001-force_dlopen_deplibs.patch [deleted file]
package/libtool/patches/100-libdir_path.patch [deleted file]
package/libtool/patches/110-no_rpath.patch [deleted file]
package/libtool/patches/120-libdir_search.patch [deleted file]

index 5b30d5007c2a95fdd202699a94ea3f46be7ba219..f105ffd81f61a1405d3107f62d36b9988a9aecf9 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libtool
-PKG_VERSION:=1.5.26
+PKG_VERSION:=2.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/libtool
-PKG_MD5SUM:=aa9c5107f3ec9ef4200eb6556f3b3c29
+#PKG_MD5SUM:=aa9c5107f3ec9ef4200eb6556f3b3c29
 
 HOST_PATCH_DIR=/dev/null
 
diff --git a/package/libtool/patches/001-force_dlopen_deplibs.patch b/package/libtool/patches/001-force_dlopen_deplibs.patch
deleted file mode 100644 (file)
index a95e5be..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/libltdl/acinclude.m4
-+++ b/libltdl/acinclude.m4
-@@ -6771,10 +6771,8 @@ AC_CACHE_CHECK([whether deplibs are load
-     ;;
-   esac
-   ])
--if test "$libltdl_cv_sys_dlopen_deplibs" != yes; then
-  AC_DEFINE([LTDL_DLOPEN_DEPLIBS], [1],
-     [Define if the OS needs help to load dependent libraries for dlopen().])
--fi
- ])# AC_LTDL_SYS_DLOPEN_DEPLIBS
diff --git a/package/libtool/patches/100-libdir_path.patch b/package/libtool/patches/100-libdir_path.patch
deleted file mode 100644 (file)
index 1132c38..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -789,6 +789,7 @@ $(srcdir)/ltmain.sh: $(srcdir)/ltmain.in
-       -rm -f ltmain.shT
-       date=`$(SHELL) $(srcdir)/mkstamp < $(srcdir)/ChangeLog` && \
-       sed -e 's/@''PACKAGE@/@PACKAGE@/' -e 's/@''VERSION@/@VERSION@/' \
-+              -e 's#@''GLOBAL_LIBDIR@#$(GLOBAL_LIBDIR)#' \
-           -e "s%@""TIMESTAMP@%$$date%" $(srcdir)/ltmain.in > ltmain.shT
-       mv -f ltmain.shT $@ || \
-       (rm -f $@ && cp ltmain.shT $@ && rm -f ltmain.shT)
---- a/ltmain.in
-+++ b/ltmain.in
-@@ -2827,7 +2827,7 @@ EOF
-             fi
-           else
-             # We cannot seem to hardcode it, guess we'll fake it.
--            add_dir="-L$libdir"
-+            add_dir="-L@GLOBAL_LIBDIR@"
-             # Try looking first in the location we're being installed to.
-             if test -n "$inst_prefix_dir"; then
-               case $libdir in
-@@ -5669,7 +5669,7 @@ fi\
-                 $echo "$modename: \`$deplib' is not a valid libtool archive" 1>&2
-                 exit $EXIT_FAILURE
-               fi
--              newdependency_libs="$newdependency_libs $libdir/$name"
-+              newdependency_libs="$newdependency_libs @GLOBAL_LIBDIR@/$name"
-               ;;
-             *) newdependency_libs="$newdependency_libs $deplib" ;;
-             esac
-@@ -5694,7 +5694,7 @@ fi\
-               $echo "$modename: \`$lib' is not a valid libtool archive" 1>&2
-               exit $EXIT_FAILURE
-             fi
--            newdlprefiles="$newdlprefiles $libdir/$name"
-+            newdlprefiles="$newdlprefiles @GLOBAL_LIBDIR@/$name"
-           done
-           dlprefiles="$newdlprefiles"
-         else
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -67,6 +67,7 @@ $(srcdir)/ltmain.sh: $(srcdir)/ltmain.in
-       -rm -f ltmain.shT
-       date=`$(SHELL) $(srcdir)/mkstamp < $(srcdir)/ChangeLog` && \
-       sed -e 's/@''PACKAGE@/@PACKAGE@/' -e 's/@''VERSION@/@VERSION@/' \
-+              -e 's#@''GLOBAL_LIBDIR@#$(GLOBAL_LIBDIR)#' \
-           -e "s%@""TIMESTAMP@%$$date%" $(srcdir)/ltmain.in > ltmain.shT
-       mv -f ltmain.shT $@ || \
-       (rm -f $@ && cp ltmain.shT $@ && rm -f ltmain.shT)
diff --git a/package/libtool/patches/110-no_rpath.patch b/package/libtool/patches/110-no_rpath.patch
deleted file mode 100644 (file)
index 685da9d..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-Well, brute force to disable rpath.
-
-Only 
--hardcode_libdir_flag_spec=$lt_[]_LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)
-+#hardcode_libdir_flag_spec=$lt_[]_LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)
-
-should be necessary....
-
---- a/libtool.m4
-+++ b/libtool.m4
-@@ -4601,16 +4601,16 @@ shlibpath_overrides_runpath=$shlibpath_o
- hardcode_action=$_LT_AC_TAGVAR(hardcode_action, $1)
- # Whether we should hardcode library paths into libraries.
--hardcode_into_libs=$hardcode_into_libs
-+hardcode_into_libs=no
- # Flag to hardcode \$libdir into a binary during linking.
- # This must work even if \$libdir does not exist.
--hardcode_libdir_flag_spec=$lt_[]_LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)
-+hardcode_libdir_flag_spec=
- # If ld is used when linking, flag to hardcode \$libdir into
- # a binary during linking. This must work even if \$libdir does
- # not exist.
--hardcode_libdir_flag_spec_ld=$lt_[]_LT_AC_TAGVAR(hardcode_libdir_flag_spec_ld, $1)
-+hardcode_libdir_flag_spec_ld=
- # Whether we need a single -rpath flag with a separated argument.
- hardcode_libdir_separator=$lt_[]_LT_AC_TAGVAR(hardcode_libdir_separator, $1)
diff --git a/package/libtool/patches/120-libdir_search.patch b/package/libtool/patches/120-libdir_search.patch
deleted file mode 100644 (file)
index 91ece84..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/ltmain.in
-+++ b/ltmain.in
-@@ -2444,8 +2444,14 @@ EOF
-           absdir="$abs_ladir"
-           libdir="$abs_ladir"
-         else
--          dir="$libdir"
--          absdir="$libdir"
-+            # Adding 'libdir' from the .la file to our library search paths
-+            # breaks crosscompilation horribly.  We cheat here and don't add
-+            # it, instead adding the path where we found the .la.  -CL
-+          dir="$abs_ladir"
-+          absdir="$abs_ladir"
-+          libdir="$abs_ladir"
-+          #dir="$libdir"
-+          #absdir="$libdir"
-         fi
-         test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes
-       else