ramips: add Poray X8 support
authorJohn Crispin <john@openwrt.org>
Thu, 1 Aug 2013 14:31:09 +0000 (14:31 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 1 Aug 2013 14:31:09 +0000 (14:31 +0000)
Signed-off-by: Felix Kaechele <heffer@fedoraproject.org>
SVN-Revision: 37639

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/uci-defaults/02_network
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/X8.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/profiles/poray.mk

index d04d990665776738b31661bb3ef3435992b0eae6..689fee71049c8ba017b9e9add6b6101d72bc5c69 100755 (executable)
@@ -141,6 +141,9 @@ get_status_led() {
        x5)
                status_led="x5:green:power"
                ;;
+       x8)
+               status_led="x8:green:power"
+               ;;
        xdxrn502j)
                status_led="xdxrn502j:green:power"
                ;;
index fa5b28ea95c7b01837ec82b00905d7de3c7fbfbb..2df7b0842bf14a33eb5954aa0882088e0560999a 100755 (executable)
@@ -228,7 +228,8 @@ ramips_setup_macs()
 
        m3 |\
        m4 |\
-       x5)
+       x5 |\
+       x8)
                lan_mac=$(mtd_get_mac_binary factory 4)
                lan_mac=$(macaddr_add "$lan_mac" -1)
                ;;
index 30732339f13070d68c446d1e1a53bce2a8063f64..6712154dc4bf0b44282ea3079e057e76bc67dfcb 100644 (file)
@@ -77,7 +77,8 @@ preinit_set_mac_address() {
                ;;
        m3 |\
        m4 |\
-       x5)
+       x5 |\
+       x8)
                mac=$(mtd_get_mac_binary factory 4)
                mac=$(macaddr_add "$mac" -1)
                ifconfig eth0 hw ether $mac 2>/dev/null
index 1bf93e30bfe010b04a45cfb9149e37c650df691a..6960c6d4015df580fb7860117ae4b2a8168f8f74 100755 (executable)
@@ -157,6 +157,9 @@ ramips_board_detect() {
        *"Poray X5")
                name="x5"
                ;;
+       *"Poray X8")
+               name="x8"
+               ;;
        *"PWH2004")
                name="pwh2004"
                ;;
index 4b80afa966f9c13aa08b073f36959d3a9c43c729..df3b32479dd1867a635438498ce7724decdb9232 100755 (executable)
@@ -76,7 +76,8 @@ platform_check_image() {
        ur-326n4g |\
        ur-336un |\
        wr512-3gn |\
-       x5)
+       x5 |\
+       x8)
                [ "$magic" != "27051956" ] && {
                        echo "Invalid image type."
                        return 1
diff --git a/target/linux/ramips/dts/X8.dts b/target/linux/ramips/dts/X8.dts
new file mode 100644 (file)
index 0000000..e7b13ca
--- /dev/null
@@ -0,0 +1,100 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+       compatible = "X8", "ralink,rt5350-soc";
+       model = "Poray X8";
+
+       palmbus@10000000 {
+               sysc@0 {
+                       ralink,pinmux = "i2c", "spi", "uartlite", "mdio", "sdram", "rgmii";
+                       ralink,gpiomux = "jtag";
+                       ralink,uartmux = "gpio";
+                       ralink,wdtmux = <1>;
+               };
+
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "gd25q64";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "gd25q64";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x7b0000>;
+                               };
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               status = "okay";
+       };
+
+       esw@10110000 {
+               status = "okay";
+               ralink,portmap = <0x2f>;
+               ralink,led_polarity = <1>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               power {
+                       label = "x8:green:power";
+                       gpios = <&gpio0 13 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 10 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       wmac@10180000 {
+               status = "okay";
+               ralink,mtd-eeprom = <&factory 0>;
+               ralink,led-polarity = <1>;
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+};
index 0a099b2d3725d1e0cf7b8f5e87fad9d2cda3d904..4bfcced46f9b13e57199ab917818c264a9714bbb 100644 (file)
@@ -479,6 +479,8 @@ Image/Build/Profile/WR6202=$(call BuildFirmware/Default8M/$(1),$(1),wr6202,WR620
 
 Image/Build/Profile/X5=$(call BuildFirmware/Poray8M/$(1),$(1),x5,X5)
 
+Image/Build/Profile/X8=$(call BuildFirmware/Poray8M/$(1),$(1),x8,X8)
+
 Image/Build/Profile/XDXRN502J=$(call BuildFirmware/Default4M/$(1),$(1),xdxrn502j,XDXRN502J)
 
 ifeq ($(SUBTARGET),rt305x)
@@ -543,6 +545,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/WR512-3GN,$(1))
        $(call Image/Build/Profile/WR6202,$(1))
        $(call Image/Build/Profile/X5,$(1))
+       $(call Image/Build/Profile/X8,$(1))
        $(call Image/Build/Profile/XDXRN502J,$(1))
 endef
 endif
index 86b9a8b8fce5cb6f11b8885a297ae4b97e6f13f4..8c1ed6194f85dece645e173b31b7d798d4f2c2e9 100644 (file)
@@ -35,3 +35,13 @@ define Profile/X5/Description
 endef
 
 $(eval $(call Profile,X5))
+
+define Profile/X8
+       NAME:=Poray X8
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-netdev kmod-ledtrig-timer
+endef
+define Profile/X8/Description
+       Package set for Poray X8 board
+endef
+
+$(eval $(call Profile,X8))