apm821xx: split MBL's rootfs.img.gz into a sysupgrade and factory image
authorChristian Lamparter <chunkeey@gmail.com>
Sun, 29 Jul 2018 09:55:16 +0000 (11:55 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 30 Jul 2018 06:12:13 +0000 (08:12 +0200)
@vahid-dan reported a issue with extracting the rpi images with
Gnome's Archive Manager:
"Ubuntu Archive Manager cannot extract the file and it just
throws a general error message: "An error occurred while
extracting files".
<https://forum.lede-project.org/t/corrupted-pre-built-v18-06-0-rc2-image-for-rpi>

The MBL's rootfs.img.gz image is generated in much the same way.
Hence this patch preemptively splits the rootfs.img.gz image into
a sysupgrade and a factory image.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/apm821xx/image/Makefile

index bfc6562431de7ccc8eaff781cae9d3327f97ffdd..00ab19602dd66ca5fca492849bac7ec4020fb0ae 100644 (file)
@@ -224,11 +224,12 @@ define Device/wd_mybooklive
   KERNEL := kernel-bin | dtb | gzip | uImage gzip
   KERNEL_INITRAMFS := kernel-bin | dtb | gzip | uImage gzip
   BOOT_SIZE := 8
-  IMAGES := rootfs.img.gz kernel.dtb
+  IMAGES := factory.img.gz kernel.dtb sysupgrade.img.gz
   DEVICE_DTB := apollo3g.dtb
   FILESYSTEMS := ext4 squashfs
+  IMAGE/factory.img.gz := boot-script | boot-img | hdd-img | gzip
   IMAGE/kernel.dtb := export-dtb
-  IMAGE/rootfs.img.gz := boot-script | boot-img | hdd-img | gzip | append-metadata
+  IMAGE/sysupgrade.img.gz := boot-script | boot-img | hdd-img | gzip | append-metadata
 endef
 
 TARGET_DEVICES += wd_mybooklive