Revert "kernel: prevent addition of scm marker to localversion"
authorFlorian Fainelli <f.fainelli@gmail.com>
Thu, 11 May 2017 21:33:41 +0000 (14:33 -0700)
committerJohn Crispin <john@phrozen.org>
Thu, 25 May 2017 07:22:43 +0000 (09:22 +0200)
This reverts commit 0df2c6563a3537ed21b28a9fb6874bf2718afd05 since it
gets in the way of identifying properly which kernel we are running.
This is particularly important if LEDE is using external kernels/git
cloned kernels. We want to make sure we only load modules from that
specific kernel.

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
include/kernel-defaults.mk

index 407c1924a152e8b87bcb402098b8ed0c4b30ac6b..b201865657376e9b7aa4170ba5987594e741fc00 100644 (file)
@@ -42,10 +42,6 @@ ifdef CONFIG_USE_SPARSE
   KERNEL_MAKEOPTS += C=1 CHECK=$(STAGING_DIR_HOST)/bin/sparse
 endif
 
-ifneq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
- KERNEL_MAKEOPTS += LOCALVERSION=
-endif
-
 export HOST_EXTRACFLAGS=-I$(STAGING_DIR_HOST)/include
 
 # defined in quilt.mk