more fixes for rstrip.sh and kernel modules - fixes #1301
authorFelix Fietkau <nbd@openwrt.org>
Fri, 9 Feb 2007 16:24:34 +0000 (16:24 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 9 Feb 2007 16:24:34 +0000 (16:24 +0000)
SVN-Revision: 6280

rules.mk
scripts/rstrip.sh

index b63fcf31c8f5f7a6934473e64992f4188263599c..a6188f4a6baaffc1aa5f5651af6a7e9d1e6fe903 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -87,8 +87,9 @@ TARGET_CONFIGURE_OPTS:= \
 
 # strip an entire directory
 RSTRIP:= \
+  NM="$(TARGET_CROSS)nm" \
   STRIP="$(STRIP)" \
-  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment -w -K '__mod*'" \
+  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
   $(SCRIPT_DIR)/rstrip.sh
 
 # where to build (and put) .ipk packages
index 252522bfaa1c718a2adeb5954400a05c1a0f80e5..6dd44f2ed272c65e84fbedc8d90a42d7dc627864 100755 (executable)
@@ -6,6 +6,23 @@
 # See /LICENSE for more information.
 #
 
+find_modparams() {
+       FILE="$1"
+       $NM "$FILE" | awk '
+BEGIN {
+       FS=" "
+}
+($3 ~ /^__module_parm_/) && ($3 !~ /^__module_parm_desc/) {
+       gsub(/__module_parm_/, "", $3)
+       printf "-K " $3 " "
+}
+($2 ~ /r/) && ($3 ~ /__param_/) {
+       gsub(/__param_/, "", $3)
+       printf "-K " $3 " "
+}
+'
+}
+
 
 SELF=${0##*/}
 
@@ -28,9 +45,11 @@ find $TARGETS -type f -a -exec file {} \; | \
   IFS=":"
   while read F S; do
     echo "$SELF: $F:$S"
-       [ "${F##*\.}" = "o" -o "${F##*\.}" = "ko" ] && \
-               eval "$STRIP_KMOD $F" || \
+       [ "${F##*\.}" = "o" -o "${F##*\.}" = "ko" ] && {
+               eval "$STRIP_KMOD -w -K '__param*' -K '__mod*' $(find_modparams "$F")$F"
+       } || {
                eval "$STRIP $F"
+       }
   done
   true
 )