kernel: fix chainiv crypto modules in 4.3+ kernels
authorSteven Barth <cyrus@openwrt.org>
Fri, 19 Feb 2016 11:49:03 +0000 (11:49 +0000)
committerSteven Barth <cyrus@openwrt.org>
Fri, 19 Feb 2016 11:49:03 +0000 (11:49 +0000)
Signed-off-by: Steven Barth <cyrus@openwrt.org>
SVN-Revision: 48745

package/kernel/linux/modules/crypto.mk

index b943e4d42d245bd539cac4402eb1624f3688bb0c..818a84623634f0280c491e4e62afa06096b56e21 100644 (file)
@@ -123,11 +123,12 @@ $(eval $(call KernelPackage,crypto-rng))
 define KernelPackage/crypto-iv
   TITLE:=CryptoAPI initialization vectors
   DEPENDS:=+kmod-crypto-manager +kmod-crypto-rng +kmod-crypto-wq
-  KCONFIG:= CONFIG_CRYPTO_BLKCIPHER2
+  KCONFIG:= CONFIG_CRYPTO_BLKCIPHER2 CONFIG_CRYPTO_ECHAINIV
   FILES:= \
        $(LINUX_DIR)/crypto/eseqiv.ko \
-       $(LINUX_DIR)/crypto/chainiv.ko
-  AUTOLOAD:=$(call AutoLoad,10,eseqiv chainiv)
+       $(LINUX_DIR)/crypto/chainiv.ko \
+       $(LINUX_DIR)/crypto/echainiv.ko@ge4.3
+  AUTOLOAD:=$(call AutoLoad,10,eseqiv chainiv echainiv@ge4.3)
   $(call AddDepends/crypto)
 endef