kernel: bump 4.9 to 4.9.202
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 18 Nov 2019 09:08:18 +0000 (10:08 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 19 Nov 2019 13:59:03 +0000 (14:59 +0100)
Refreshed all patches.

Altered patches:
- 902-debloat_proc.patch

Compile-tested on: none
Runtime-tested on: none

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.9/040-mm-add-support-for-releasing-multiple-instances-of-a.patch
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/generic/hack-4.9/207-disable-modorder.patch
target/linux/generic/hack-4.9/660-fq_codel_defaults.patch
target/linux/generic/hack-4.9/721-phy_packets.patch
target/linux/generic/hack-4.9/902-debloat_proc.patch
target/linux/generic/pending-4.9/655-increase_skb_pad.patch

index 511d6680b6a125cbdc288452d18b8a696e751a3a..c826b45c515c3d5d62d009cd04dec50d3d031e4e 100644 (file)
@@ -6,11 +6,11 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.9 = .199
+LINUX_VERSION-4.9 = .202
 LINUX_VERSION-4.14 = .152
 LINUX_VERSION-4.19 = .82
 
-LINUX_KERNEL_HASH-4.9.199 = 0f2531f0908e320ee49954e8d84406db659073b202abc514bcc999ceaa3f7ed5
+LINUX_KERNEL_HASH-4.9.202 = 8108ec1cd10fc40821c84e9f087dba10b1767aad66596f4a36925faef55e4ebf
 LINUX_KERNEL_HASH-4.14.152 = a9239fd9d341aae07b48a8e7a2afd528fe5cde2617d783454c71e6f3dae2b0aa
 LINUX_KERNEL_HASH-4.19.82 = 58d96d6c2c5ee8288fe9714891e4037a18f457b008e369e33fc744afc2cb595d
 
index d4b60d4559b2e9129d2b6f313c46f5b0742b9050..4656bb1db3b4ec966f9d4ed671c019dcd4a591b2 100644 (file)
@@ -41,7 +41,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
 
 --- a/include/linux/gfp.h
 +++ b/include/linux/gfp.h
-@@ -506,6 +506,8 @@ extern void free_hot_cold_page(struct pa
+@@ -529,6 +529,8 @@ extern void free_hot_cold_page(struct pa
  extern void free_hot_cold_page_list(struct list_head *list, bool cold);
  
  struct page_frag_cache;
index 3eae2ef0bd29f2ac6ab2857de438d21f1af1df3c..4fd101db27b55ea5f5ca57ed7df6bc5191d4f0f6 100644 (file)
@@ -137,7 +137,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
 --- a/drivers/net/can/c_can/c_can.c
 +++ b/drivers/net/can/c_can/c_can.c
-@@ -1070,7 +1070,7 @@ static int c_can_poll(struct napi_struct
+@@ -1079,7 +1079,7 @@ static int c_can_poll(struct napi_struct
  
  end:
        if (work_done < quota) {
@@ -668,7 +668,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
 --- a/drivers/net/ethernet/hisilicon/hip04_eth.c
 +++ b/drivers/net/ethernet/hisilicon/hip04_eth.c
-@@ -559,7 +559,7 @@ refill:
+@@ -561,7 +561,7 @@ refill:
                priv->reg_inten |= RCV_INT;
                writel_relaxed(priv->reg_inten, priv->base + PPE_INTEN);
        }
index f03c62e025353c0c4864bca20077523bf8afb513..62f67ac95d21a6fc87c0cefae0d0a61781ba1b62 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1228,7 +1228,6 @@ all: modules
+@@ -1240,7 +1240,6 @@ all: modules
  
  PHONY += modules
  modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        @$(kecho) '  Building modules, stage 2.';
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
-@@ -1258,7 +1257,6 @@ _modinst_:
+@@ -1270,7 +1269,6 @@ _modinst_:
                rm -f $(MODLIB)/build ; \
                ln -s $(CURDIR) $(MODLIB)/build ; \
        fi
index ea461e189dcebcc453882519a890a4d614dbcda0..db77f691e7eeebcd5338ed483de1afd43c705df9 100644 (file)
@@ -24,4 +24,4 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +#endif
        q->drop_batch_size = 64;
        q->quantum = psched_mtu(qdisc_dev(sch));
-       q->perturbation = prandom_u32();
+       get_random_bytes(&q->perturbation, sizeof(q->perturbation));
index d22c8730325f32845cd8f0f1fa1494562cb25650..feb3569f04136a238b04a891a93fcd8136c5b93a 100644 (file)
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
   */
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2339,6 +2339,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -2340,6 +2340,10 @@ static inline int pskb_trim(struct sk_bu
        return (len < skb->len) ? __pskb_trim(skb, len) : 0;
  }
  
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  /**
   *    pskb_trim_unique - remove end from a paged unique (not cloned) buffer
   *    @skb: buffer to alter
-@@ -2459,16 +2463,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -2460,16 +2464,6 @@ static inline struct sk_buff *dev_alloc_
  }
  
  
index 8bed139d1b3d04e3d24b1284611162dcea9e34c7..cb13f0ff0255a0a41b3a77b4d2fe7ceb7dd106dc 100644 (file)
@@ -249,10 +249,10 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #endif
  #ifdef CONFIG_PROC_FS
 -      proc_create("buddyinfo", S_IRUGO, NULL, &fragmentation_file_operations);
--      proc_create("pagetypeinfo", S_IRUGO, NULL, &pagetypeinfo_file_ops);
+-      proc_create("pagetypeinfo", 0400, NULL, &pagetypeinfo_file_ops);
 +      if (!IS_ENABLED(CONFIG_PROC_STRIPPED)) {
 +              proc_create("buddyinfo", S_IRUGO, NULL, &fragmentation_file_operations);
-+              proc_create("pagetypeinfo", S_IRUGO, NULL, &pagetypeinfo_file_ops);
++              proc_create("pagetypeinfo", 0400, NULL, &pagetypeinfo_file_ops);
 +              proc_create("zoneinfo", S_IRUGO, NULL, &proc_zoneinfo_file_operations);
 +      }
        proc_create("vmstat", S_IRUGO, NULL, &proc_vmstat_file_operations);
index de96d9a41dc8bed3db194c08c0a1388c268807fc..87f9bb6a95e0abebe79877e4f12043f3958516f9 100644 (file)
@@ -9,7 +9,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2303,7 +2303,7 @@ static inline int pskb_network_may_pull(
+@@ -2304,7 +2304,7 @@ static inline int pskb_network_may_pull(
   * NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
   */
  #ifndef NET_SKB_PAD