Update to .21
authorFlorian Fainelli <florian@openwrt.org>
Wed, 30 May 2007 19:07:03 +0000 (19:07 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 30 May 2007 19:07:03 +0000 (19:07 +0000)
SVN-Revision: 7408

target/linux/brcm63xx-2.6/config/default
target/linux/brcm63xx-2.6/files/arch/mips/bcm963xx/prom.c
target/linux/brcm63xx-2.6/files/drivers/serial/bcm63xx_cons.c
target/linux/brcm63xx-2.6/patches/001-bcm963xx.patch
target/linux/brcm63xx-2.6/patches/002-bcm963xx_serial.patch [new file with mode: 0644]

index 491d4e05792b4448e797cb8437359460ddea4119..ff3e7d329434227f5ca852a69bb8c8eb0677bb8b 100644 (file)
@@ -2,16 +2,20 @@ CONFIG_32BIT=y
 # CONFIG_64BIT is not set
 # CONFIG_64BIT_PHYS_ADDR is not set
 # CONFIG_8139TOO is not set
+# CONFIG_ARCH_HAS_ILOG2_U32 is not set
+# CONFIG_ARCH_HAS_ILOG2_U64 is not set
 CONFIG_AUDIT=y
 CONFIG_AUDIT_GENERIC=y
 # CONFIG_B44 is not set
 CONFIG_BASE_SMALL=0
 CONFIG_BCM963XX=y
 CONFIG_BINFMT_MISC=m
+CONFIG_BITREVERSE=y
 # CONFIG_BLK_DEV_INITRD is not set
 CONFIG_BLK_DEV_IO_TRACE=y
 # CONFIG_BLK_DEV_LOOP is not set
 # CONFIG_BLK_DEV_NBD is not set
+# CONFIG_BROADCOM_PHY is not set
 # CONFIG_BSD_DISKLABEL is not set
 CONFIG_BSD_PROCESS_ACCT_V3=y
 CONFIG_CFE=y
@@ -73,63 +77,48 @@ CONFIG_CRYPTO_SHA1=y
 # CONFIG_CRYPTO_WP512 is not set
 CONFIG_DAVICOM_PHY=m
 # CONFIG_DDB5477 is not set
-# CONFIG_DEBUG_DRIVER is not set
 CONFIG_DEBUG_FS=y
-# CONFIG_DEBUG_INFO is not set
-CONFIG_DEBUG_KERNEL=y
-# CONFIG_DEBUG_KOBJECT is not set
-# CONFIG_DEBUG_LIST is not set
-# CONFIG_DEBUG_LOCKING_API_SELFTESTS is not set
-# CONFIG_DEBUG_LOCK_ALLOC is not set
-# CONFIG_DEBUG_MUTEXES is not set
-# CONFIG_DEBUG_RT_MUTEXES is not set
-# CONFIG_DEBUG_RWSEMS is not set
-# CONFIG_DEBUG_SLAB is not set
-# CONFIG_DEBUG_SPINLOCK is not set
-# CONFIG_DEBUG_SPINLOCK_SLEEP is not set
-# CONFIG_DEBUG_STACK_USAGE is not set
-# CONFIG_DEBUG_VM is not set
 CONFIG_DEFAULT_BIC=y
 CONFIG_DEFAULT_CFQ=y
 # CONFIG_DEFAULT_DEADLINE is not set
 CONFIG_DEFAULT_IOSCHED="cfq"
 CONFIG_DEFAULT_TCP_CONG="bic"
 # CONFIG_DEFAULT_VEGAS is not set
-CONFIG_DETECT_SOFTLOCKUP=y
-# CONFIG_DLM is not set
 # CONFIG_DM9000 is not set
 CONFIG_DMA_NEED_PCI_MAP_STATE=y
 CONFIG_DMA_NONCOHERENT=y
-CONFIG_DNOTIFY=y
 CONFIG_DUMMY=m
 CONFIG_ELF_CORE=y
 CONFIG_EQUALIZER=m
-# CONFIG_EXT2_FS is not set
-# CONFIG_EXT3_FS is not set
-CONFIG_FIRMWARE_EDID=y
+# CONFIG_EXT3_FS_POSIX_ACL is not set
+# CONFIG_EXT3_FS_SECURITY is not set
+CONFIG_EXT3_FS_XATTR=y
 # CONFIG_FIXED_PHY is not set
-CONFIG_FORCED_INLINING=y
+CONFIG_FS_MBCACHE=m
 CONFIG_FS_POSIX_ACL=y
+CONFIG_FUSE_FS=m
 CONFIG_FW_LOADER=m
 CONFIG_GENERIC_FIND_NEXT_BIT=y
+# CONFIG_GENERIC_GPIO is not set
+# CONFIG_GENERIC_HARDIRQS_NO__DO_IRQ is not set
 # CONFIG_GEN_RTC is not set
 # CONFIG_HAMRADIO is not set
+CONFIG_HAS_IOMEM=y
+CONFIG_HAS_IOPORT=y
+CONFIG_HID=m
+# CONFIG_HID_DEBUG is not set
+# CONFIG_HID_FF is not set
 CONFIG_HWMON=y
 # CONFIG_HWMON_DEBUG_CHIP is not set
 CONFIG_HW_HAS_PCI=y
 CONFIG_HW_RANDOM=y
 CONFIG_HZ=250
 # CONFIG_HZ_100 is not set
-# CONFIG_HZ_1024 is not set
-# CONFIG_HZ_128 is not set
 CONFIG_HZ_250=y
-# CONFIG_HZ_256 is not set
-# CONFIG_HZ_48 is not set
 # CONFIG_I2C is not set
 # CONFIG_IDE is not set
-CONFIG_INITRAMFS_ROOT_GID=0
-CONFIG_INITRAMFS_ROOT_UID=0
-CONFIG_INITRAMFS_SOURCE="../../root"
+CONFIG_INOTIFY=y
+CONFIG_INOTIFY_USER=y
 CONFIG_INPUT=m
 # CONFIG_INPUT_EVDEV is not set
 CONFIG_INPUT_KEYBOARD=y
@@ -151,21 +140,15 @@ CONFIG_IOSCHED_CFQ=y
 CONFIG_IPV6_PRIVACY=y
 CONFIG_IPV6_ROUTE_INFO=y
 CONFIG_IPV6_TUNNEL=m
-# CONFIG_IP_DCCP_DEBUG is not set
 CONFIG_IP_MROUTE=y
 # CONFIG_IP_NF_ARPTABLES is not set
-# CONFIG_IP_NF_CT_PROTO_SCTP is not set
 # CONFIG_IP_NF_MATCH_ADDRTYPE is not set
-# CONFIG_IP_NF_MATCH_HASHLIMIT is not set
-CONFIG_IP_NF_NAT_TFTP=y
 # CONFIG_IP_NF_TARGET_LOG is not set
 # CONFIG_IP_NF_TARGET_NETMAP is not set
 CONFIG_IP_NF_TARGET_REJECT=m
 # CONFIG_IP_NF_TARGET_SAME is not set
-CONFIG_IP_NF_TFTP=y
 CONFIG_IP_PIMSM_V1=y
 CONFIG_IP_PIMSM_V2=y
-# CONFIG_IP_ROUTE_FWMARK is not set
 CONFIG_IP_SCTP=m
 CONFIG_IRQ_CPU=y
 # CONFIG_JFFS2_COMPRESSION_OPTIONS is not set
@@ -173,7 +156,6 @@ CONFIG_JFFS2_FS_DEBUG=0
 CONFIG_JFFS2_SUMMARY=y
 # CONFIG_JFS_FS is not set
 CONFIG_KALLSYMS=y
-CONFIG_KALLSYMS_ALL=y
 CONFIG_KALLSYMS_EXTRA_PASS=y
 CONFIG_KEYBOARD_ATKBD=m
 # CONFIG_KEYBOARD_LKKBD is not set
@@ -181,9 +163,7 @@ CONFIG_KEYBOARD_ATKBD=m
 # CONFIG_KEYBOARD_STOWAWAY is not set
 # CONFIG_KEYBOARD_SUNKBD is not set
 # CONFIG_KEYBOARD_XTKBD is not set
-# CONFIG_KGDB is not set
 CONFIG_KMOD=y
-# CONFIG_LAN_SAA9730 is not set
 CONFIG_LBD=y
 # CONFIG_LEDS_TRIGGER_HEARTBEAT is not set
 # CONFIG_LLC2 is not set
@@ -196,7 +176,6 @@ CONFIG_MAGIC_SYSRQ=y
 CONFIG_MARVELL_PHY=m
 CONFIG_MII=m
 # CONFIG_MINIX_FS is not set
-CONFIG_MINI_FO=y
 CONFIG_MIPS=y
 # CONFIG_MIPS_ATLAS is not set
 # CONFIG_MIPS_BOSPORUS is not set
@@ -221,7 +200,6 @@ CONFIG_MIPS_MT_DISABLED=y
 # CONFIG_MIPS_PB1550 is not set
 # CONFIG_MIPS_SEAD is not set
 # CONFIG_MIPS_SIM is not set
-# CONFIG_MIPS_UNCACHED is not set
 # CONFIG_MIPS_VPE_LOADER is not set
 # CONFIG_MIPS_XXS1500 is not set
 CONFIG_MODULE_FORCE_UNLOAD=y
@@ -237,6 +215,7 @@ CONFIG_MOUSE_PS2=m
 CONFIG_MTD=y
 # CONFIG_MTD_ABSENT is not set
 CONFIG_MTD_BCM963XX=y
+CONFIG_MTD_BLKDEVS=y
 CONFIG_MTD_BLOCK=y
 # CONFIG_MTD_BLOCK2MTD is not set
 CONFIG_MTD_CFI=y
@@ -257,7 +236,6 @@ CONFIG_MTD_CHAR=y
 CONFIG_MTD_CMDLINE_PARTS=y
 # CONFIG_MTD_COMPLEX_MAPPINGS is not set
 CONFIG_MTD_CONCAT=y
-# CONFIG_MTD_CSTM_MIPS_IXX is not set
 CONFIG_MTD_DEBUG=y
 CONFIG_MTD_DEBUG_VERBOSE=3
 # CONFIG_MTD_DOC2000 is not set
@@ -300,32 +278,25 @@ CONFIG_NET_ACT_SIMP=m
 CONFIG_NET_KEY=y
 CONFIG_NET_SCH_CLK_GETTIMEOFDAY=y
 # CONFIG_NET_SCH_CLK_JIFFIES is not set
+CONFIG_NET_SCH_FIFO=y
 # CONFIG_NET_VENDOR_3COM is not set
 CONFIG_NLS=y
 CONFIG_NLS_ASCII=m
-# CONFIG_NLS_CODEPAGE_437 is not set
-# CONFIG_NTFS_FS is not set
 # CONFIG_PAGE_SIZE_16KB is not set
 CONFIG_PAGE_SIZE_4KB=y
 # CONFIG_PAGE_SIZE_64KB is not set
 # CONFIG_PAGE_SIZE_8KB is not set
-# CONFIG_PCI_DEBUG is not set
 CONFIG_PHYLIB=m
 # CONFIG_PMC_YOSEMITE is not set
+# CONFIG_PNPACPI is not set
 # CONFIG_PNX8550_JBS is not set
-# CONFIG_PNX8550_V2PCI is not set
+# CONFIG_PNX8550_STB810 is not set
 CONFIG_POSIX_MQUEUE=y
-# CONFIG_PROVE_LOCKING is not set
 CONFIG_QSEMI_PHY=m
-# CONFIG_RCU_TORTURE_TEST is not set
-# CONFIG_REISERFS_FS is not set
 CONFIG_RELAY=y
 # CONFIG_ROMFS_FS is not set
 # CONFIG_RTC is not set
-# CONFIG_RT_MUTEX_TESTER is not set
-# CONFIG_RUNTIME_DEBUG is not set
 CONFIG_RWSEM_GENERIC_SPINLOCK=y
-# CONFIG_SCHEDSTATS is not set
 CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
 # CONFIG_SCSI_MULTI_LUN is not set
 # CONFIG_SCTP_DBG_MSG is not set
@@ -333,9 +304,6 @@ CONFIG_SCHED_NO_NO_OMIT_FRAME_POINTER=y
 CONFIG_SCTP_HMAC_MD5=y
 # CONFIG_SCTP_HMAC_NONE is not set
 # CONFIG_SCTP_HMAC_SHA1 is not set
-# CONFIG_SENSORS_ABITUGURU is not set
-# CONFIG_SENSORS_F71805F is not set
-# CONFIG_SENSORS_VT1211 is not set
 # CONFIG_SERIAL_8250 is not set
 CONFIG_SERIO=m
 CONFIG_SERIO_I8042=m
@@ -362,7 +330,7 @@ CONFIG_SHAPER=m
 # CONFIG_SPARSEMEM_STATIC is not set
 CONFIG_SQUASHFS_EMBEDDED=y
 CONFIG_SQUASHFS_VMALLOC=y
-CONFIG_SYN_COOKIES=y
+CONFIG_SYSVIPC_SYSCTL=y
 CONFIG_SYS_HAS_CPU_MIPS32_R1=y
 CONFIG_SYS_SUPPORTS_32BIT_KERNEL=y
 CONFIG_SYS_SUPPORTS_ARBIT_HZ=y
@@ -383,10 +351,11 @@ CONFIG_TIPC=m
 CONFIG_TRAD_SIGNALS=y
 # CONFIG_UNUSED_SYMBOLS is not set
 # CONFIG_USB_EHCI_HCD is not set
+# CONFIG_USB_GTCO is not set
 # CONFIG_USB_UHCI_HCD is not set
+CONFIG_USB_YEALINK=m
 # CONFIG_VIA_RHINE is not set
 CONFIG_VLAN_8021Q=m
 CONFIG_VM_EVENT_COUNTERS=y
 CONFIG_WAN_ROUTER=m
 # CONFIG_WATCHDOG is not set
-# CONFIG_XFS_FS is not set
index 23e97200b0e37d888d10febe766389456e98e6ba..e02d31c9ed6d64e4a198b477cce2b464c41d79f1 100644 (file)
@@ -67,8 +67,7 @@ void __init prom_init(void)
        mips_machtype = MACH_BCM;
 }
 
-unsigned long __init prom_free_prom_memory(void)
+void __init prom_free_prom_memory(void)
 {
        /* We do not have any memory to free */
-       return 0;
 }
index 4693779773508973a81898c526e9ec3535ccce45..b026aa10ab18da558acf027651586126b0ee3321 100644 (file)
@@ -75,7 +75,7 @@ typedef struct bcm_serial {
 
        struct async_icount icount;     /* keep track of things ... */
        struct tty_struct *tty; /* tty associated */
-       struct termios normal_termios;
+       struct ktermios normal_termios;
 
        wait_queue_head_t open_wait;
        wait_queue_head_t close_wait;
@@ -107,8 +107,8 @@ typedef struct bcm_serial {
 static struct bcm_serial multi[BCM_NUM_UARTS];
 static struct bcm_serial *lines[BCM_NUM_UARTS];
 static struct tty_driver *serial_driver;
-static struct termios *serial_termios[BCM_NUM_UARTS];
-static struct termios *serial_termios_locked[BCM_NUM_UARTS];
+static struct ktermios *serial_termios[BCM_NUM_UARTS];
+static struct ktermios *serial_termios_locked[BCM_NUM_UARTS];
 
 
 static void bcm_stop(struct tty_struct *tty);
@@ -135,7 +135,7 @@ static void send_break(struct bcm_serial *info, int duration);
 static int bcm_ioctl(struct tty_struct *tty, struct file *file,
                     unsigned int cmd, unsigned long arg);
 static void bcm_set_termios(struct tty_struct *tty,
-                           struct termios *old_termios);
+                           struct ktermios *old_termios);
 static void bcm63xx_cons_close(struct tty_struct *tty, struct file *filp);
 static void bcm_hangup(struct tty_struct *tty);
 static int block_til_ready(struct tty_struct *tty, struct file *filp,
@@ -721,7 +721,7 @@ static int bcm_ioctl(struct tty_struct *tty, struct file *file,
 }
 
 static void bcm_set_termios(struct tty_struct *tty,
-                           struct termios *old_termios)
+                           struct ktermios *old_termios)
 {
        struct bcm_serial *info = (struct bcm_serial *) tty->driver_data;
 
@@ -894,7 +894,6 @@ static int bcm63xx_cons_open(struct tty_struct *tty, struct file *filp)
 
 #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
        info->pgrp = process_group(current);
-       info->session = current->signal->session;
 #else
        info->session = current->session;
        info->pgrp = current->pgrp;
index 42fc728ab76e3942e858fe9471a09d2d846b7df4..fbdda380c0612a0d5426b02a75827af4ec2a2287 100644 (file)
@@ -147,14 +147,6 @@ diff -urN linux-2.6.19/arch/mips/pci/Makefile linux-2.6.19.new/arch/mips/pci/Mak
  
  #
  # These are still pretty much in the old state, watch, go blind.
-diff -urN linux-2.6.19/drivers/serial/Makefile linux-2.6.19.new/drivers/serial/Makefile
---- linux-2.6.19/drivers/serial/Makefile       2006-11-29 22:57:37.000000000 +0100
-+++ linux-2.6.19.new/drivers/serial/Makefile   2006-12-16 18:49:17.000000000 +0100
-@@ -56,3 +56,4 @@
- obj-$(CONFIG_SERIAL_SGI_IOC3) += ioc3_serial.o
- obj-$(CONFIG_SERIAL_ATMEL) += atmel_serial.o
- obj-$(CONFIG_SERIAL_NETX) += netx-serial.o
-+obj-$(CONFIG_BCM963XX) += bcm63xx_cons.o
 diff -urN linux-2.6.19/include/asm-mips/bootinfo.h linux-2.6.19.new/include/asm-mips/bootinfo.h
 --- linux-2.6.19/include/asm-mips/bootinfo.h   2006-11-29 22:57:37.000000000 +0100
 +++ linux-2.6.19.new/include/asm-mips/bootinfo.h       2006-12-16 18:46:31.000000000 +0100
diff --git a/target/linux/brcm63xx-2.6/patches/002-bcm963xx_serial.patch b/target/linux/brcm63xx-2.6/patches/002-bcm963xx_serial.patch
new file mode 100644 (file)
index 0000000..9055417
--- /dev/null
@@ -0,0 +1,8 @@
+diff -urN linux-2.6.21.1/drivers/serial/Makefile linux-2.6.21.1.new/drivers/serial/Makefile
+--- linux-2.6.21.1/drivers/serial/Makefile     2007-04-27 23:49:26.000000000 +0200
++++ linux-2.6.21.1.new/drivers/serial/Makefile 2007-05-30 20:32:27.000000000 +0200
+@@ -60,3 +60,4 @@
+ obj-$(CONFIG_SERIAL_UARTLITE) += uartlite.o
+ obj-$(CONFIG_SERIAL_NETX) += netx-serial.o
+ obj-$(CONFIG_SERIAL_OF_PLATFORM) += of_serial.o
++obj-$(CONFIG_BCM963XX) += bcm63xx_cons.o