dnsmasq: add more options for interface binding (#4900)
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 9 Apr 2009 14:51:15 +0000 (14:51 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 9 Apr 2009 14:51:15 +0000 (14:51 +0000)
SVN-Revision: 15172

package/dnsmasq/Makefile
package/dnsmasq/files/dhcp.conf
package/dnsmasq/files/dnsmasq.init

index 3599fa09ade7640db3078c94f52f5f6c708c57ee..5fe1509601c04bdb311004f62bbf27407eb92463 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.47
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index 837be313ee6fbce46db775cc0d46db659fd2706c..f34a0e91580e96c124668bd47ced6c23d9aa949e 100644 (file)
@@ -12,6 +12,8 @@ config dnsmasq
        option leasefile        '/tmp/dhcp.leases'
        option resolvfile       '/tmp/resolv.conf.auto'
        #list server            '/mycompany.local/1.2.3.4'
+       #option nonwildcard     0
+       #option interfaces      ''
 
 config dhcp lan
        option interface        lan
index 870414900f8007edbefc1a2fc75c7bb5199eded9..0b2f6303904ad1ef3102a350112d495f7714db52 100644 (file)
@@ -57,6 +57,7 @@ dnsmasq() {
        append_bool "$cfg" boguspriv "-b"
        append_bool "$cfg" expandhosts "-E"
        append_bool "$cfg" enable_tftp "--enable-tftp"
+       append_bool "$cfg" nonwildcard "-z"
 
        append_parm "$cfg" dnsforwardmax "-0"
        append_parm "$cfg" port "-p"
@@ -71,6 +72,7 @@ dnsmasq() {
        append_parm "$cfg" "resolvfile" "-r"
        append_parm "$cfg" "tftp_root" "--tftp-root"
        append_parm "$cfg" "dhcp_boot" "--dhcp-boot"
+       append_parm "$cfg" "interfaces" "-i"
 
        config_get leasefile $cfg leasefile
        [ -e "$leasefile" ] || touch "$leasefile"