xburst: fix imagebuilder
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 28 May 2015 12:25:45 +0000 (12:25 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 28 May 2015 12:25:45 +0000 (12:25 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 45805

target/linux/xburst/image/Makefile

index 49bb254164ced11d4e31476bec0023d3096984dd..58436d5359bf5c8f0b648f8138ea39c0a62278b8 100644 (file)
@@ -31,8 +31,12 @@ define MkImageGzip
                -d $(1).gz $(2)
 endef
 
+define Image/Prepare
+       $(call MkImageGzip,$(KDIR)/vmlinux,$(KDIR)/uimage)
+endef
+
 define Image/BuildKernel
-       $(call MkImageGzip,$(KDIR)/vmlinux,$(UIMAGE))
+       cp $(KDIR)/uimage $(UIMAGE)
 endef
 
 define Image/Build/squashfs