x86_64: fix PARTUUID format with leading zeros
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 24 Mar 2015 10:06:40 +0000 (10:06 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 24 Mar 2015 10:06:40 +0000 (10:06 +0000)
Otherwise the root device won't be found in 1/16 of the generated images
(whenever the signature starts with a zero digit).

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
SVN-Revision: 44959

target/linux/x86_64/image/Makefile

index e8d9ac11587dc5961422a3d9cf5a619ee6b6818d..cd80bb1de8f99db80ce37f0cfeabf46b206ac6b2 100644 (file)
@@ -40,7 +40,7 @@ ifneq ($(GRUB_TERMINALS),)
   GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
 endif
 
   GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
 endif
 
-SIGNATURE:=$(shell dd if=/dev/urandom bs=4 count=1 2>/dev/null | hexdump -v -e '"%02x"')
+SIGNATURE:=$(shell dd if=/dev/urandom bs=4 count=1 2>/dev/null | hexdump -v -e '"%08x"')
 ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
 ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(SIGNATURE)-02)
 
 ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
 ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(SIGNATURE)-02)