mt76: update to the latest version
authorFelix Fietkau <nbd@nbd.name>
Wed, 1 Feb 2017 15:37:14 +0000 (16:37 +0100)
committerFelix Fietkau <nbd@nbd.name>
Wed, 1 Feb 2017 16:49:55 +0000 (17:49 +0100)
Uses upstream code to parse DT supported band/frequency information.
Update existing .dts files to the new format and remove unnecessary
overrides.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
32 files changed:
package/kernel/mt76/Makefile
target/linux/ramips/dts/ArcherC20i.dts
target/linux/ramips/dts/ArcherC50.dts
target/linux/ramips/dts/ArcherMR200.dts
target/linux/ramips/dts/DIR-860L-B1.dts
target/linux/ramips/dts/FIREWRT.dts
target/linux/ramips/dts/GL-MT750.dts
target/linux/ramips/dts/MAC1200RV2.dts
target/linux/ramips/dts/MIWIFI-MINI.dts
target/linux/ramips/dts/MZK-750DHP.dts
target/linux/ramips/dts/MZK-EX750NP.dts
target/linux/ramips/dts/Newifi-D1.dts
target/linux/ramips/dts/PBR-M1.dts
target/linux/ramips/dts/PSG1208.dts
target/linux/ramips/dts/PSG1218.dts
target/linux/ramips/dts/RE6500.dts
target/linux/ramips/dts/SAP-G3200U3.dts
target/linux/ramips/dts/SK-WB8.dts
target/linux/ramips/dts/W2914NSV2.dtsi
target/linux/ramips/dts/WCR-1166DS.dts
target/linux/ramips/dts/WF-2881.dts
target/linux/ramips/dts/WHR-1166D.dts
target/linux/ramips/dts/WITI.dts
target/linux/ramips/dts/WL-WN575A3.dts
target/linux/ramips/dts/WNDR3700V5.dts
target/linux/ramips/dts/WSR-1166.dts
target/linux/ramips/dts/WSR-600.dts
target/linux/ramips/dts/Y1.dtsi
target/linux/ramips/dts/ZBT-APE522II.dts
target/linux/ramips/dts/ZBT-WG2626.dts
target/linux/ramips/dts/ZBT-WG3526.dtsi
target/linux/ramips/dts/mt7628an.dtsi

index 5e7761093cf6dcf250f1aa48bbda7b868301d0e6..658a3191b125b6ecc2596bfefe7dceb4302d2a01 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/openwrt/mt76
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2017-01-31
-PKG_SOURCE_VERSION:=3c8caafc5e150db79f714b958a51cee8f242f309
-PKG_MIRROR_HASH:=c03c166466cb7ea825e52cd085511045e3847d927ba2bde2b8fb46595a3ed13a
+PKG_SOURCE_DATE:=2017-02-01
+PKG_SOURCE_VERSION:=184e068b6fa82a4b26dc71d3c877599a99a33e9c
+PKG_MIRROR_HASH:=097200a7f315de45eab4227d6dae7335874e8364adc4e444e518a201681d389b
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_BUILD_PARALLEL:=1
index 711274e62578079eeef67116511a9875f40ff54d..cbbdf8ab803eb02c64d5412f7a41ef924e704c35 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&radio 32768>;
-                       mediatek,2ghz = <0>;
                };
        };
 };
index 3924cc41fa5c14b3eaf2f3977bdc1866dcf0840e..c9863a1f319a862947ea0b5e935977d6638b4eb0 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&radio 32768>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                        mtd-mac-address = <&rom 0xf100>;
                        mtd-mac-address-increment = <(-1)>;
                };
index 93fb048d49b14564233a465a426e68334b939991..25be6bcd6b7d5840941e9a052f8aa640dc48f511 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&radio 32768>;
-                       mediatek,2ghz = <0>;
                };
        };
 };
index 98c9d8a0bb77790cf7c3433b4116a0bd1e8aae53..cc6c32b14603fa7514417411e2cf77d3fba8285d 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&radio 0x2000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&radio 0>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                };
        };
 };
index 1871de99be9606c72fbe9422d2eb91e15e5815c2..c1509ccc552edf3931987571515ef633f65c3ee4 100644 (file)
@@ -93,7 +93,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                };
        };
 };
index 46679842bc52c6aa052b2713a48539c0b27cec3f..939d012594ac6fec4d03a04ffbc9622981f830b3 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
                };
        };
 };
index f52be3c51c15b46af6779c823ca0e3dd0d2c0dfb..0929a013fdeffa616dac1f214dc72cd347f936f8 100644 (file)
@@ -88,7 +88,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&art 0x1000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index 6d8b28c3ccb9ff5d12b4c0909a483488a7066d10..d8c5e7cd1fb803ee486ac6e821d17e70d958752c 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index 589b19e52cb9a3c43c6b6dc861d1f68c46fff1a1..5a2e4b49bf8efad9ce696ea440f037b976c1b857 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
                };
        };
 };
index ec2ca5fc4b463e6630e8f598358ffc5b0b384868..858a8fe23fae7e0aaec310ddd6b8aae7ad5e6e66 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
                };
        };
 };
index 2d128ac6d2e3cc306634491aea8c298bc7db0def..89bc8515a62d2d4c6e75a3b932f7ff7a6ce7ab6d 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 };
index 9a0c713daa917a2e1205bafc6118ef3c9823aa92..7baf07499bf3c65f8be8934ea1c165676769bebf 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 };
index e9b66395dff05bb02c85609a2bd467f7ca1ee5c1..6227bda9513c918b2209091d7710b090f2459d6e 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index b777c9b1f28966257d9834f71ae0f0e49e6a0370..38ad25e99833dc9e6b50ed4f8270d6b17f8cff9a 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index 3fe875db1227d61a6eb12486ed6c091414d11cc4..07439fa573de163705c318b08d03f88b28a2dc60 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                };
        };
 };
index 7be6e033c7927d302c465669c95124e4cff018b3..dbaa6a31cf095a7a11965509c72bed4e96c4dfd2 100644 (file)
@@ -95,7 +95,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                };
        };
 };
index 87adc9ae1d943cd6dccfebbc1265db25ba6f45d7..f5da941031d852b67ca1c48019c2177b34102628 100644 (file)
@@ -92,7 +92,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 };
index 7b11a0f6a22ec7649e78c42397d161eb5f14b293..51ec1618408d8cb809625d1612b0bdaf93412f5b 100644 (file)
        status = "okay";
 
        pcie0 {
-               wifi@14c3,7662 {
-                       compatible = "pci14c3,7662";
+               wifi@14c3,7603 {
+                       compatible = "pci14c3,7603";
                        reg = <0x0000 0 0 0 0>;
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 
        pcie1 {
-               wifi@14c3,7603 {
-                       compatible = "pci14c3,7603";
+               wifi@14c3,7662 {
+                       compatible = "pci14c3,7662";
                        reg = <0x0000 0 0 0 0>;
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index ad3f21ba677cd52c03458d1a05dac67d0b83661c..34734ceda58966f62c0461003dafccdebc47fa09 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index 84a14e4e0195d2eea5cd5efe2310de40f9b48abe..80676fa896d2a67a77eb5722ff1b41dae2e970e9 100644 (file)
@@ -85,7 +85,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
@@ -94,7 +94,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                };
        };
 };
index c3b85da2b341d9c588550d0cfad784e7c6ef8bd1..69282d8fd26c4914bae94abf4fa58e3659356730 100644 (file)
                        compatible = "pci0,0";
                        reg = <0x0000 0 0 0 0>;
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index de0c517d0ce63513a824bcf467b68266594009cb..91f669364de6c587f6e83adefef1fa4c7ee91b28 100644 (file)
@@ -89,7 +89,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                        mtd-mac-address = <&factory 0xe000>;
                };
        };
@@ -99,7 +99,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                        mtd-mac-address = <&factory 0xe000>;
                };
        };
index 267482407f582d7326077b131b4735bcde61fec4..2deadd3a9573a2872d8075709d6becd7dc9a0565 100644 (file)
@@ -77,7 +77,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index bb879a1441eac5b4f34170bb412abce89348e934..ec97ac805dd77651e3994cab17b8291e7012509d 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 };
index ab6a9a4e3f5a753e86ab705b538bbd69b868fe9c..5d5725cfdecfc6a3003ec88d368a0c4f5de45f7d 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 };
index 63206b4d613d16bc65f8f93f4aa334e4dccecc9d..3f7238cfa76fcfc2f4c9d6e90886c0bac5891c08 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 };
index 1d5f1ef074355fe7f34999e2bb7e33283d0934a0..0d0623bbe88502f9bb6534f39f21594b6c0c6ef9 100644 (file)
@@ -85,7 +85,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index f57012997770e80b5a71cb816291dc8704174f73..2213ca9cca6d8554dd1453f01e4e6ffff54f5954 100644 (file)
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index a75ca89aa891f8ac1d7f505b389dd76f97163b24..65541a5a445cd5ccaf8a113825b3b56a85d59b6e 100644 (file)
@@ -93,7 +93,7 @@
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 
                        reg = <0x0000 0 0 0 0>;
                        device_type = "pci";
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
+                       ieee80211-freq-limit = <2400000 2500000>;
                };
        };
 };
index e48ef3a25b039b5f2c39b52783ba23cec186adbf..582e42083920c465588f14e59e10eafe735640fb 100644 (file)
@@ -88,7 +88,6 @@
                        compatible = "pci14c3,7603";
                        reg = <0x0000 0 0 0 0>;
                        mediatek,mtd-eeprom = <&factory 0x0000>;
-                       mediatek,5ghz = <0>;
                };
        };
 
@@ -97,7 +96,7 @@
                        compatible = "pci14c3,7662";
                        reg = <0x0000 0 0 0 0>;
                        mediatek,mtd-eeprom = <&factory 0x8000>;
-                       mediatek,2ghz = <0>;
+                       ieee80211-freq-limit = <5000000 6000000>;
                };
        };
 };
index dc3ba9e323a76b9a9c0fea8c1a715b4f8319f5ce..b64a87a493e4b1eab151c096cb3c18f00aea7798 100644 (file)
                status = "disabled";
 
                mediatek,mtd-eeprom = <&factory 0x0000>;
-               mediatek,5ghz = <0>;
        };
 };