uboot-at91: Add support for SAMA5D2 Xplained board
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Wed, 13 Sep 2017 18:51:21 +0000 (11:51 -0700)
committerJohn Crispin <john@phrozen.org>
Wed, 20 Sep 2017 07:01:31 +0000 (09:01 +0200)
Add support for SAMA5D2 Xplained board and options to select & build
u-boot configs for different media storage.

Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
package/boot/uboot-at91/Makefile

index 2c95377b0fb0f95cc7cabd0ba2b7ec429b303136..e2d3ed032259c2d1dece8df5563f874fb759f9b8 100644 (file)
@@ -42,11 +42,26 @@ define uboot/sama5d3_xplained_mmc
   BUILD_DEVICES:=at91-sama5d3_xplained
 endef
 
+define uboot/sama5d2_xplained_spiflash
+  TITLE:=U-Boot for the SAMA5D2 Xplained board (SPI Flash)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d2_xplained
+endef
+
+define uboot/sama5d2_xplained_mmc
+  TITLE:=U-Boot for the SAMA5D2 Xplained board (SDcard/EMMC)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=at91-sama5d2_xplained
+endef
+
 UBOOT_TARGETS := \
        at91sam9m10g45ek_nandflash \
        at91sam9x5ek_nandflash \
     sama5d3_xplained_nandflash \
-    sama5d3_xplained_mmc
+    sama5d3_xplained_mmc \
+    sama5d2_xplained_mmc \
+    sama5d2_xplained_spiflash
+
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \