mediatek: mt7622: Do not set CPU_SUBTYPE for Cortex A53
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 9 Jun 2018 16:37:11 +0000 (18:37 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 18 Jun 2018 19:21:55 +0000 (21:21 +0200)
Neon and vfpv4 are mandatory extensions in the ARM64 instruction set
now, do not activate them explicitly. GCC will make use of these
extension now by default.

This makes it possible to share the toolchain with other Cortex A53
SoCs.
Compile tested only.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit 10ce015c652b1e48c1c113604e26481626fa6059)

target/linux/mediatek/mt7622/target.mk

index 1fc33b8af8264cfb9ba927b1dcc1e30af7160a86..b27186911406354ab58f70f941b4345df3a7ae11 100644 (file)
@@ -2,7 +2,6 @@ ARCH:=aarch64
 SUBTARGET:=mt7622
 BOARDNAME:=MT7622
 CPU_TYPE:=cortex-a53
-CPU_SUBTYPE:=neon-vfpv4
 
 KERNELNAME:=Image dtbs