ipq806x: increase kernel partition size for the Netgear r7800
authorStefan Lippers-Hollmann <s.l-h@gmx.de>
Fri, 18 May 2018 01:00:41 +0000 (03:00 +0200)
committerJohn Crispin <john@phrozen.org>
Tue, 22 May 2018 18:34:14 +0000 (20:34 +0200)
Starting with kernel 4.14 and gcc 7, the kernel doesn't fit into the
2 MB reserved for the kernel partition by the OEM firmware anymore.

This patch increases the kernel partition from 2 MB to 4 MB, at the
expense of the rootfs, for all supported kernels.

WARNING: This breaks sysupgrade! Flashing a firmware containing this
changed partitioning from an older image with 2 MB reserved for the
kernel partion requires the tftp recovery procedure, thereby losing
all settings.

This patch is based on a corresponding change by Pavel Kubelun
<be.dissent@gmail.com> and has been tested by Michael Yartys
<michael.yartys@protonmail.com>

Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
target/linux/ipq806x/files-4.14/arch/arm/boot/dts/qcom-ipq8065-r7800.dts
target/linux/ipq806x/files-4.9/arch/arm/boot/dts/qcom-ipq8065-r7800.dts
target/linux/ipq806x/image/Makefile

index 63cb42a3e2f4bfc2518c1f72cd8080fb26267d04..a590fadd0e872cdc5a2d53aab2f03444220e6566 100644 (file)
 
                                        kernel@1480000 {
                                                label = "kernel";
-                                               reg = <0x1480000 0x0200000>;
+                                               reg = <0x1480000 0x0400000>;
                                        };
 
-                                       ubi@1680000 {
+                                       ubi@1880000 {
                                                label = "ubi";
-                                               reg = <0x1680000 0x1E00000>;
+                                               reg = <0x1880000 0x1C00000>;
                                        };
 
                                        netgear@3480000 {
index 63cb42a3e2f4bfc2518c1f72cd8080fb26267d04..a590fadd0e872cdc5a2d53aab2f03444220e6566 100644 (file)
 
                                        kernel@1480000 {
                                                label = "kernel";
-                                               reg = <0x1480000 0x0200000>;
+                                               reg = <0x1480000 0x0400000>;
                                        };
 
-                                       ubi@1680000 {
+                                       ubi@1880000 {
                                                label = "ubi";
-                                               reg = <0x1680000 0x1E00000>;
+                                               reg = <0x1880000 0x1C00000>;
                                        };
 
                                        netgear@3480000 {
index a737e165b04454b65e67b674ebd7001a1034601f..e5df7275a16ceaa52b279ec49959e003b6700b6a 100644 (file)
@@ -149,7 +149,7 @@ TARGET_DEVICES += netgear_r7500v2
 define Device/netgear_r7800
        $(call Device/DniImage)
        DEVICE_DTS := qcom-ipq8065-r7800
-       KERNEL_SIZE := 2097152
+       KERNEL_SIZE := 4194304
        NETGEAR_BOARD_ID := R7800
        NETGEAR_HW_ID := 29764958+0+128+512+4x4+4x4+cascade
        BLOCKSIZE := 128k