do old style image generation for the mpc8377wlan, as the current bootloader doesn...
authorImre Kaloz <kaloz@openwrt.org>
Mon, 8 Feb 2010 20:11:01 +0000 (20:11 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 8 Feb 2010 20:11:01 +0000 (20:11 +0000)
SVN-Revision: 19553

target/linux/mpc83xx/image/Makefile

index ed00128999e12964b0a485652c1c0aa2735b16b7..9b241919f6e1385c279f8a820a5fcf9e9fa271f2 100644 (file)
@@ -9,10 +9,12 @@ include $(INCLUDE_DIR)/image.mk
 
 
 define Image/Prepare
+       $(LINUX_DIR)/scripts/dtc/dtc -O dtb -R 4 -S 0x20000 $(LINUX_DIR)/arch/powerpc/boot/dts/mpc8377_wlan.dts > $(BIN_DIR)/openwrt-mpc8377_wlan.dtb
 endef
 
 define Image/BuildKernel
        cp $(LINUX_DIR)/arch/powerpc/boot/dtbImage.rb600.elf $(BIN_DIR)/openwrt-$(BOARD)-rb600.elf
+       cp $(LINUX_DIR)/arch/powerpc/boot/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
 endef
 
 define Image/Build
@@ -22,7 +24,7 @@ endef
 define Image/Build/squashfs
        $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage.fit.mpc8377_wlan bs=3072k conv=sync; \
+               dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=3072k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
        ) > $(BIN_DIR)/openwrt-$(BOARD)-mpc8377_wlan-$(1).img
 endef