procd: fix service file tracking
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 18 Dec 2013 15:38:28 +0000 (15:38 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 18 Dec 2013 15:38:28 +0000 (15:38 +0000)
The instance_config_move() function in the procd instance managing code is
missing a blobmsg_list_move() call to update the tracked file items with the
newly calculated checksums in case of a file change.

Without that change, services are always reloaded after the first change to
a tracked file regardless of whether there are any subsequent changes or not.

Add a missing instance of blobmsg_list_free() as well.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 39132

package/system/procd/Makefile

index 932e991052c495d578270659440b090ee1738fb1..33ba8d1ef80df9176b06129ddb1cc0dedd9fb59f 100644 (file)
@@ -1,14 +1,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2013-12-09
+PKG_VERSION:=2013-12-18
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=b76325945d31280b2ffecf898bfc62aa5f3d22d4
+PKG_SOURCE_VERSION:=2dc572df0e3002263c0a49ebbc329ed1b6c42a01
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1