ramips: rt288x: nuke built-in MTD partition maps
authorGabor Juhos <juhosg@openwrt.org>
Sun, 19 Feb 2012 17:52:11 +0000 (17:52 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 19 Feb 2012 17:52:11 +0000 (17:52 +0000)
SVN-Revision: 30649

target/linux/ramips/files/arch/mips/ralink/rt288x/mach-f5d8235-v1.c
target/linux/ramips/files/arch/mips/ralink/rt288x/mach-rt-n15.c
target/linux/ramips/files/arch/mips/ralink/rt288x/mach-v11st-fe.c
target/linux/ramips/files/arch/mips/ralink/rt288x/mach-wli-tx4-ag300n.c
target/linux/ramips/image/Makefile

index 76b10530ec1ac61d57bbcbffcad206b828c53e4d..7679572bb5856a32cb9ce31592e034381d805524 100644 (file)
@@ -10,9 +10,6 @@
 
 #include <linux/init.h>
 #include <linux/platform_device.h>
-#include <linux/mtd/mtd.h>
-#include <linux/mtd/partitions.h>
-#include <linux/mtd/physmap.h>
 
 #include <asm/mach-ralink/machine.h>
 #include <asm/mach-ralink/dev-gpio-buttons.h>
 #define F5D8235_KEYS_POLL_INTERVAL     20
 #define F5D8235_KEYS_DEBOUNCE_INTERVAL (3 * F5D8235_KEYS_POLL_INTERVAL)
 
-static struct mtd_partition f5d8235_partitions[] = {
-       {
-               .name   = "uboot",
-               .offset = 0,
-               .size   = 0x050000,
-               .mask_flags = MTD_WRITEABLE,
-       }, {
-               .name   = "kernel and rootfs",
-               .offset = 0x050000,
-               .size   = 0x790000,
-       }, {
-               .name   = "rootfs",
-               .offset = 0x1D0000,
-               .size   = 0x610000,
-       }, {
-               .name   = "nvram",
-               .offset = 0x7E0000,
-               .size   = 0x010000,
-       }, {
-               .name   = "factory",
-               .offset = 0x7F0000,
-               .size   = 0x010000,
-       }
-};
-
 static struct rtl8366_platform_data f5d8235_rtl8366s_data = {
        .gpio_sda       = F5D8235_GPIO_RTL8366_SDA,
        .gpio_sck       = F5D8235_GPIO_RTL8366_SCK,
@@ -110,10 +82,7 @@ static void __init f5d8235_init(void)
 {
        rt288x_gpio_init(RT2880_GPIO_MODE_UART0 | RT2880_GPIO_MODE_I2C);
 
-       rt288x_flash0_data.nr_parts = ARRAY_SIZE(f5d8235_partitions);
-       rt288x_flash0_data.parts = f5d8235_partitions;
        rt288x_register_flash(0);
-
        rt288x_register_wifi();
        rt288x_register_wdt();
 
index 4315328da8e1ad53196d6f1c81bbdb762bb75ff9..1085b82f9199e7d2a3b70b6e304b697d567fcb53 100644 (file)
@@ -10,9 +10,6 @@
 
 #include <linux/init.h>
 #include <linux/platform_device.h>
-#include <linux/mtd/mtd.h>
-#include <linux/mtd/partitions.h>
-#include <linux/mtd/physmap.h>
 #include <linux/rtl8366.h>
 #include <linux/ethtool.h>
 
 #define RT_N15_KEYS_POLL_INTERVAL      20
 #define RT_N15_KEYS_DEBOUNCE_INTERVAL  (3 * RT_N15_KEYS_POLL_INTERVAL)
 
-static struct mtd_partition rt_n15_partitions[] = {
-       {
-               .name   = "u-boot",
-               .offset = 0,
-               .size   = 0x030000,
-               .mask_flags = MTD_WRITEABLE,
-       }, {
-               .name   = "u-boot-env",
-               .offset = 0x030000,
-               .size   = 0x010000,
-               .mask_flags = MTD_WRITEABLE,
-       }, {
-               .name   = "factory",
-               .offset = 0x040000,
-               .size   = 0x010000,
-               .mask_flags = MTD_WRITEABLE,
-       }, {
-               .name   = "kernel",
-               .offset = 0x050000,
-               .size   = 0x0d0000,
-       }, {
-               .name   = "rootfs",
-               .offset = 0x120000,
-               .size   = 0x2e0000,
-       }, {
-               .name   = "firmware",
-               .offset = 0x050000,
-               .size   = 0x3b0000,
-       }
-};
-
 static struct gpio_led rt_n15_leds_gpio[] __initdata = {
        {
                .name           = "rt-n15:blue:power",
@@ -109,8 +75,6 @@ static void __init rt_n15_init(void)
 {
        rt288x_gpio_init(RT2880_GPIO_MODE_UART0 | RT2880_GPIO_MODE_I2C);
 
-       rt288x_flash0_data.nr_parts = ARRAY_SIZE(rt_n15_partitions);
-       rt288x_flash0_data.parts = rt_n15_partitions;
        rt288x_register_flash(0);
 
        ramips_register_gpio_leds(-1, ARRAY_SIZE(rt_n15_leds_gpio),
index e2511d4df74cf3d79bcd9461e0ec7cff13417722..667fe92dc0509cb5b50a6be6aea2d0b038cc7fe8 100644 (file)
@@ -10,9 +10,6 @@
 
 #include <linux/init.h>
 #include <linux/platform_device.h>
-#include <linux/mtd/mtd.h>
-#include <linux/mtd/partitions.h>
-#include <linux/mtd/physmap.h>
 #include <linux/ethtool.h>
 
 #include <asm/mach-ralink/machine.h>
@@ -48,39 +45,10 @@ static struct gpio_keys_button v11st_fe_gpio_buttons[] __initdata = {
        }
 };
 
-static struct mtd_partition v11st_fe_partitions[] = {
-       {
-               .name   = "u-boot",
-               .offset = 0,
-               .size   = 0x030000,
-               .mask_flags = MTD_WRITEABLE,
-       }, {
-               .name   = "u-boot-env",
-               .offset = 0x030000,
-               .size   = 0x010000,
-               .mask_flags = MTD_WRITEABLE,
-       }, {
-               .name   = "factory",
-               .offset = 0x040000,
-               .size   = 0x010000,
-               .mask_flags = MTD_WRITEABLE,
-       }, {
-               .name   = "kernel",
-               .offset = 0x050000,
-               .size   = 0x140000,
-       }, {
-               .name   = "rootfs",
-               .offset = 0x190000,
-               .size   = 0x210000,
-       }
-};
-
 static void __init rt_v11st_fe_init(void)
 {
        rt288x_gpio_init(RT2880_GPIO_MODE_UART0);
 
-       rt288x_flash0_data.nr_parts = ARRAY_SIZE(v11st_fe_partitions);
-       rt288x_flash0_data.parts = v11st_fe_partitions;
        rt288x_register_flash(0);
 
        ramips_register_gpio_leds(-1, ARRAY_SIZE(v11st_fe_leds_gpio),
index 9b310d05882ec7a8f5a899c3ac145bbecfcf20d1..02fac0b3c5507529f021fe723b6af21a71c315e3 100644 (file)
@@ -11,9 +11,6 @@
 #include <linux/init.h>
 #include <linux/ethtool.h>
 #include <linux/platform_device.h>
-#include <linux/mtd/mtd.h>
-#include <linux/mtd/partitions.h>
-#include <linux/mtd/physmap.h>
 
 #include <asm/mach-ralink/machine.h>
 #include <asm/mach-ralink/dev-gpio-buttons.h>
 #define WLI_TX4_AG300N_KEYS_POLL_INTERVAL      20
 #define WLI_TX4_AG300N_KEYS_DEBOUNCE_INTERVAL  (3 * WLI_TX4_AG300N_KEYS_POLL_INTERVAL)
 
-static struct mtd_partition wli_tx4_ag300n_partitions[] = {
-       {
-               .name   = "u-boot",
-               .offset = 0,
-               .size   = 0x030000,
-               .mask_flags = MTD_WRITEABLE,
-       },
-       {
-               .name   = "u-boot-env",
-               .offset = 0x030000,
-               .size   = 0x010000,
-               .mask_flags = MTD_WRITEABLE,
-       },
-       {
-               .name   = "factory",
-               .offset = 0x040000,
-               .size   = 0x010000,
-               .mask_flags = MTD_WRITEABLE,
-       },
-       {
-               .name   = "kernel",
-               .offset = 0x050000,
-               .size   = 0x0d0000,
-       },
-       {
-               .name   = "rootfs",
-               .offset = 0x120000,
-               .size   = 0x2d0000,
-       },
-       {
-               .name   = "user",
-               .offset = 0x3f0000,
-               .size   = 0x010000,
-       },
-       {
-               .name   = "firmware",
-               .offset = 0x050000,
-               .size   = 0x3a0000,
-       },
-};
-
 static struct gpio_led wli_tx4_ag300n_leds_gpio[] __initdata = {
        {
                .name           = "buffalo:blue:power",
@@ -131,10 +87,7 @@ static void __init wli_tx4_ag300n_init(void)
                                     ARRAY_SIZE(wli_tx4_ag300n_gpio_buttons),
                                     wli_tx4_ag300n_gpio_buttons);
 
-       rt288x_flash0_data.nr_parts = ARRAY_SIZE(wli_tx4_ag300n_partitions);
-       rt288x_flash0_data.parts = wli_tx4_ag300n_partitions;
        rt288x_register_flash(0);
-
        rt288x_register_wifi();
        rt288x_register_wdt();
 
index 770b12e62e6cd20f0099f104d3d15ef32b95d0e8..4692d68d57c9a6a3f0282b4ef3f4af773c3aad8b 100644 (file)
@@ -144,16 +144,16 @@ define Image/Build/Template/GENERIC_4M
        $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_4M,851968,3014656)
 endef
 
-mtdlayout_8M=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),7040k(rootfs),7872k@0x50000(firmware)
-kernel_size_8M=851968
-rootfs_size_8M=7208960
+mtdlayout_8M=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,896k(kernel),6976k(rootfs),7872k@0x50000(firmware)
+kernel_size_8M=917504
+rootfs_size_8M=7143424
 define Image/Build/Template/GENERIC_8M
        $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_8M,$(kernel_size_8M),$(rootfs_size_8M))
 endef
 
-mtdlayout_dir300b1=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(devdata)ro,64k(devconf)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
-mtd_dir300b1_kernel_part_size=851968
-mtd_dir300b1_rootfs_part_size=3014656
+mtdlayout_dir300b1=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(devdata)ro,64k(devconf)ro,896k(kernel),2880k(rootfs),3776k@0x50000(firmware)
+mtd_dir300b1_kernel_part_size=917504
+mtd_dir300b1_rootfs_part_size=2949120
 define Image/Build/Template/DIR300B1
        $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_dir300b1,$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
        mkwrgimg -s $(4) -d /dev/mtdblock/2 \