toplevel.mk: drop LD_LIBRARY_PATH overrides
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 3 Oct 2015 09:49:24 +0000 (09:49 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 3 Oct 2015 09:49:24 +0000 (09:49 +0000)
Overriding LD_LIBRARY_PATH for host utilities frequently leads to problems
with host executables loading shared libraries from the staging_dir, leading
to crashes due to incompatible ABIs.

Since most host utilties either embed a proper rpath or are reworked to link
statically we do not need the workaround anymore.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 47103

include/toplevel.mk

index 70f4691678b35e114f0c002260e49af8c3e58e23..0e6c55ae08d0dc323a31e283f276163bfd7f4353 100644 (file)
@@ -22,8 +22,6 @@ endif
 HOSTCC ?= $(CC)
 export RELEASE
 export REVISION
-export LD_LIBRARY_PATH:=$(subst ::,:,$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(TOPDIR)/staging_dir/host/lib)
-export DYLD_LIBRARY_PATH:=$(subst ::,:,$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(TOPDIR)/staging_dir/host/lib)
 export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
 export MAKE_JOBSERVER=$(filter --jobserver%,$(MAKEFLAGS))