imagebuilder: properly escape single quotes in device titles
authorJo-Philipp Wich <jo@mein.io>
Thu, 26 Jan 2017 09:13:23 +0000 (10:13 +0100)
committerJo-Philipp Wich <jo@mein.io>
Thu, 26 Jan 2017 09:16:53 +0000 (10:16 +0100)
The name "Plat'Home OpenBlocks AX3" causes the imagebuilders "make info"
command to fail with:

    bash: -c: line 0: syntax error near unexpected token `('
    bash: -c: line 0: `echo;  [...]'
    Makefile:99: recipe for target '_call_info' failed

Properly escape single quotes to avoid breaking the echo commands.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/imagebuilder/files/Makefile

index 493012ff7205c22b1d2303851de8ed67794c1c30..af633b21636358c40e83ab7c83279b1733b3fb8d 100644 (file)
@@ -74,7 +74,7 @@ include $(INCLUDE_DIR)/target.mk
 
 USER_PROFILE ?= $(firstword $(PROFILE_NAMES))
 PROFILE_LIST = $(foreach p,$(PROFILE_NAMES), \
-       echo '$(patsubst DEVICE_%,%,$(p)):'; $(if $($(p)_NAME),echo '    $($(p)_NAME)'; ) echo '    Packages: $($(p)_PACKAGES)'; \
+       echo '$(patsubst DEVICE_%,%,$(p)):'; $(if $($(p)_NAME),echo '    $(subst ','"'"',$($(p)_NAME))'; ) echo '    Packages: $($(p)_PACKAGES)'; \
 )
 
 .profiles.mk: .targetinfo