imagebuilder: fail with error if the passed profile name does not exist
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 10 Jan 2015 18:19:59 +0000 (18:19 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 10 Jan 2015 18:19:59 +0000 (18:19 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 43916

target/imagebuilder/files/Makefile

index 8136111b670a0eadddf25edbdb181aff874e7b23..f3bfec1e31def0a9fb629257720e7173734228f5 100644 (file)
@@ -78,6 +78,7 @@ define Profile
   endif
   $(1)_NAME:=$(NAME)
   $(1)_PACKAGES:=$(PACKAGES)
+  PROFILE_NAMES += $(1)
   PROFILE_LIST += \
        echo '$(1):'; [ -z '$(NAME)' ] || echo '        $(NAME)'; echo '        Packages: $(PACKAGES)';
 endef
@@ -167,6 +168,13 @@ info:
        (unset PROFILE FILES PACKAGES MAKEFLAGS; $(MAKE) -s _call_info)
 
 image:
+ifneq ($(PROFILE),)
+  ifeq ($(filter $(PROFILE),$(PROFILE_NAMES)),)
+       @echo 'Profile "$(PROFILE)" does not exist!'
+       @echo 'Use "make info" to get a list of available profile names.'
+       @exit 1
+  endif
+endif
        (unset PROFILE FILES PACKAGES MAKEFLAGS; \
        $(MAKE) _call_image \
                $(if $(PROFILE),USER_PROFILE="$(PROFILE)") \