ar71xx: fix build of lzma-loader with binutils 2.25.1
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 12 Sep 2015 18:57:37 +0000 (18:57 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 12 Sep 2015 18:57:37 +0000 (18:57 +0000)
To make the lzma-loader build with binutils 2.25.1 it is needed to
remove the .MIPS.abiflags section otherwise I get the following compile
error:

mips-openwrt-linux-musl-objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S loader loader.bin
mips-openwrt-linux-musl-objcopy: Warning: Writing section `.text' to huge (ie negative) file offset 0xffffffff80a00000.
mips-openwrt-linux-musl-objcopy:loader.bin[.text]: File truncated

This should close #20487.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 46893

target/linux/ar71xx/image/lzma-loader/src/Makefile

index 8038b2fba9375a42db4be8af98407845b6c80e37..5f10bdb8f1499f24f00a8bf4d53f370fef88bd1e 100644 (file)
@@ -27,7 +27,8 @@ LD            := $(CROSS_COMPILE)ld
 OBJCOPY                := $(CROSS_COMPILE)objcopy
 OBJDUMP                := $(CROSS_COMPILE)objdump
 
 OBJCOPY                := $(CROSS_COMPILE)objcopy
 OBJDUMP                := $(CROSS_COMPILE)objdump
 
-BIN_FLAGS      := -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
+BIN_FLAGS      := -O binary -R .reginfo -R .note -R .comment -R .mdebug \
+                  -R .MIPS.abiflags -S
 
 CFLAGS         = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
                  -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \
 
 CFLAGS         = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
                  -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \