kernel: add kmod-ipvlan support
authorChen Minqiang <ptpt52@gmail.com>
Wed, 21 Apr 2021 05:27:42 +0000 (13:27 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 30 Apr 2021 21:51:23 +0000 (23:51 +0200)
This kmod is similar to macvlan with the difference being that the
endpoints have the same mac address.

It is useful on cloud where only one mac address allowed on port,
where macvlan not works but ipvlan would.

One use case is where multiple IPs and gateways assign on one net port

Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
package/kernel/linux/modules/netdevices.mk
target/linux/generic/config-5.10
target/linux/generic/config-5.4

index bc6ed2c7aa8f08490a031dfcd595de00db4735b1..5c1f3b2ee73d60ba6e302e93b9478714249317ae 100644 (file)
@@ -885,6 +885,22 @@ endef
 $(eval $(call KernelPackage,macvlan))
 
 
+define KernelPackage/ipvlan
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=IP-VLAN support
+  KCONFIG:=CONFIG_IPVLAN
+  FILES:=$(LINUX_DIR)/drivers/net/ipvlan/ipvlan.ko
+  AUTOLOAD:=$(call AutoProbe,ipvlan)
+endef
+
+define KernelPackage/ipvlan/description
+ A kernel module which allows one to create virtual interfaces that
+ map packets to or from specific IP addresses to a particular interface
+endef
+
+$(eval $(call KernelPackage,ipvlan))
+
+
 define KernelPackage/tulip
   TITLE:=Tulip family network device support
   DEPENDS:=@PCI_SUPPORT +kmod-mii
index 00c60c12270ca852ffb9ed2349a391d38fbf9e3f..11d05aba6f506053bb843c2703eb693238509897 100644 (file)
@@ -2662,6 +2662,7 @@ CONFIG_IPV6_NDISC_NODETYPE=y
 # CONFIG_IPV6_TUNNEL is not set
 # CONFIG_IPV6_VTI is not set
 # CONFIG_IPVLAN is not set
+# CONFIG_IPVTAP is not set
 # CONFIG_IPW2100 is not set
 # CONFIG_IPW2100_DEBUG is not set
 CONFIG_IPW2100_MONITOR=y
index e8527f8068f4811c8bb55d9ac97ca44157aece57..8a93027d4dd1e18785233492c0917a8c6082201d 100644 (file)
@@ -2434,6 +2434,7 @@ CONFIG_IPV6_NDISC_NODETYPE=y
 # CONFIG_IPV6_TUNNEL is not set
 # CONFIG_IPV6_VTI is not set
 # CONFIG_IPVLAN is not set
+# CONFIG_IPVTAP is not set
 # CONFIG_IPW2100 is not set
 # CONFIG_IPW2100_DEBUG is not set
 CONFIG_IPW2100_MONITOR=y