uboot-imx6: update to v2013.07
authorLuka Perkov <luka@openwrt.org>
Thu, 29 Aug 2013 23:06:31 +0000 (23:06 +0000)
committerLuka Perkov <luka@openwrt.org>
Thu, 29 Aug 2013 23:06:31 +0000 (23:06 +0000)
Update includes upstream support for Wandboard Quad too.

Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 37858

package/boot/uboot-imx6/Makefile
package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch
package/boot/uboot-imx6/patches/110-wandboard-owrt-env-patch [deleted file]
package/boot/uboot-imx6/patches/110-wandboard-owrt-env.patch [new file with mode: 0644]

index 16465c78e2df8aeaeabe328175291a95b36963d8..21c7b09718b76bca05cae653beb99a122709498f 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2013.04
+PKG_VERSION:=2013.07
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=21bf962d69938ed4ed783b792b2b074e
+PKG_MD5SUM:=8445162690052e6afd4b8f87af2bb557
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,9 +32,14 @@ define uboot/wandboard_dl
   TITLE:=U-Boot for the Wandboard Dual Lite
 endef
 
+define uboot/wandboard_quad
+  TITLE:=U-Boot for the Wandboard Quad
+endef
+
 UBOOTS := \
        wandboard_solo \
-       wandboard_dl
+       wandboard_dl \
+       wandboard_quad
 
 define Package/uboot/template
 define Package/uboot-imx6-$(1)
index f4fb2c683e86ff8e7def73e9a86d138bfd994634..f847c5a790fef4d8ea10ffad011688619b1ce8d7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/configs/wandboard.h
 +++ b/include/configs/wandboard.h
-@@ -206,4 +206,7 @@
+@@ -242,4 +242,7 @@
  #define CONFIG_CMD_CACHE
  #endif
  
diff --git a/package/boot/uboot-imx6/patches/110-wandboard-owrt-env-patch b/package/boot/uboot-imx6/patches/110-wandboard-owrt-env-patch
deleted file mode 100644 (file)
index e14f563..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
---- a/include/configs/wandboard.h
-+++ b/include/configs/wandboard.h
-@@ -47,7 +47,7 @@
- #undef CONFIG_CMD_IMLS
--#define CONFIG_BOOTDELAY              5
-+#define CONFIG_BOOTDELAY              3
- #define CONFIG_SYS_MEMTEST_START      0x10000000
- #define CONFIG_SYS_MEMTEST_END                (CONFIG_SYS_MEMTEST_START + 500 * SZ_1M)
-@@ -83,13 +83,15 @@
- #if defined(CONFIG_MX6DL)
- #define CONFIG_DEFAULT_FDT_FILE               "imx6dl-wandboard.dtb"
-+#define CONFIG_OWRT_NAME              "openwrt-imx6dl-wandboard-uImage.itb"
- #elif defined(CONFIG_MX6S)
- #define CONFIG_DEFAULT_FDT_FILE               "imx6s-wandboard.dtb"
-+#define CONFIG_OWRT_NAME              "openwrt-imx6s-wandboard-uImage.itb"
- #endif
- #define CONFIG_EXTRA_ENV_SETTINGS \
-       "script=boot.scr\0" \
--      "uimage=uImage\0" \
-+      "uimage=" CONFIG_OWRT_NAME "\0" \
-       "console=ttymxc0\0" \
-       "fdt_high=0xffffffff\0" \
-       "initrd_high=0xffffffff\0" \
-@@ -103,11 +105,11 @@
-       "mmcargs=setenv bootargs console=${console},${baudrate} " \
-               "root=${mmcroot}\0" \
-       "loadbootscript=" \
--              "fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \
-+              "ext2load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \
-       "bootscript=echo Running bootscript from mmc ...; " \
-               "source\0" \
--      "loaduimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}\0" \
--      "loadfdt=fatload mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${fdt_file}\0" \
-+      "loaduimage=ext2load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}\0" \
-+      "loadfdt=ext2load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${fdt_file}\0" \
-       "mmcboot=echo Booting from mmc ...; " \
-               "run mmcargs; " \
-               "if test ${boot_fdt} = yes || test ${boot_fdt} = try; then " \
-@@ -122,30 +124,6 @@
-                       "fi; " \
-               "else " \
-                       "bootm; " \
--              "fi;\0" \
--      "netargs=setenv bootargs console=${console},${baudrate} " \
--              "root=/dev/nfs " \
--      "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
--              "netboot=echo Booting from net ...; " \
--              "run netargs; " \
--              "if test ${ip_dyn} = yes; then " \
--                      "setenv get_cmd dhcp; " \
--              "else " \
--                      "setenv get_cmd tftp; " \
--              "fi; " \
--              "${get_cmd} ${uimage}; " \
--              "if test ${boot_fdt} = yes || test ${boot_fdt} = try; then " \
--                      "if ${get_cmd} ${fdt_addr} ${fdt_file}; then " \
--                              "bootm ${loadaddr} - ${fdt_addr}; " \
--                      "else " \
--                              "if test ${boot_fdt} = try; then " \
--                                      "bootm; " \
--                              "else " \
--                                      "echo WARN: Cannot load the DT; " \
--                              "fi; " \
--                      "fi; " \
--              "else " \
--                      "bootm; " \
-               "fi;\0"
- #define CONFIG_BOOTCOMMAND \
-@@ -155,10 +133,10 @@
-                  "else " \
-                          "if run loaduimage; then " \
-                                  "run mmcboot; " \
--                         "else run netboot; " \
-+                         "else echo WARN: Can not boot the image; " \
-                          "fi; " \
-                  "fi; " \
--         "else run netboot; fi"
-+         "fi"
- /* Miscellaneous configurable options */
- #define CONFIG_SYS_LONGHELP
diff --git a/package/boot/uboot-imx6/patches/110-wandboard-owrt-env.patch b/package/boot/uboot-imx6/patches/110-wandboard-owrt-env.patch
new file mode 100644 (file)
index 0000000..6869c85
--- /dev/null
@@ -0,0 +1,90 @@
+--- a/include/configs/wandboard.h
++++ b/include/configs/wandboard.h
+@@ -51,7 +51,7 @@
+ #define CONFIG_CMD_BMODE
+ #define CONFIG_CMD_SETEXPR
+-#define CONFIG_BOOTDELAY              5
++#define CONFIG_BOOTDELAY              3
+ #define CONFIG_SYS_MEMTEST_START      0x10000000
+ #define CONFIG_SYS_MEMTEST_END                (CONFIG_SYS_MEMTEST_START + 500 * SZ_1M)
+@@ -103,15 +103,18 @@
+ #if defined(CONFIG_MX6DL)
+ #define CONFIG_DEFAULT_FDT_FILE               "imx6dl-wandboard.dtb"
++#define CONFIG_OWRT_NAME              "openwrt-imx6dl-wandboard-uImage.itb"
+ #elif defined(CONFIG_MX6Q)
+ #define CONFIG_DEFAULT_FDT_FILE               "imx6q-wandboard.dtb"
++#define CONFIG_OWRT_NAME              "openwrt-imx6q-wandboard-uImage.itb"
+ #elif defined(CONFIG_MX6S)
+ #define CONFIG_DEFAULT_FDT_FILE               "imx6s-wandboard.dtb"
++#define CONFIG_OWRT_NAME              "openwrt-imx6s-wandboard-uImage.itb"
+ #endif
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+       "script=boot.scr\0" \
+-      "uimage=uImage\0" \
++      "uimage=" CONFIG_OWRT_NAME "\0" \
+       "console=ttymxc0\0" \
+       "fdt_high=0xffffffff\0" \
+       "initrd_high=0xffffffff\0" \
+@@ -139,11 +142,11 @@
+       "mmcargs=setenv bootargs console=${console},${baudrate} " \
+               "root=${mmcroot}\0" \
+       "loadbootscript=" \
+-              "fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \
++              "ext2load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \
+       "bootscript=echo Running bootscript from mmc ...; " \
+               "source\0" \
+-      "loaduimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}\0" \
+-      "loadfdt=fatload mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${fdt_file}\0" \
++      "loaduimage=ext2load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}\0" \
++      "loadfdt=ext2load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${fdt_file}\0" \
+       "mmcboot=echo Booting from mmc ...; " \
+               "run mmcargs; " \
+               "if test ${boot_fdt} = yes || test ${boot_fdt} = try; then " \
+@@ -158,30 +161,6 @@
+                       "fi; " \
+               "else " \
+                       "bootm; " \
+-              "fi;\0" \
+-      "netargs=setenv bootargs console=${console},${baudrate} " \
+-              "root=/dev/nfs " \
+-      "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
+-              "netboot=echo Booting from net ...; " \
+-              "run netargs; " \
+-              "if test ${ip_dyn} = yes; then " \
+-                      "setenv get_cmd dhcp; " \
+-              "else " \
+-                      "setenv get_cmd tftp; " \
+-              "fi; " \
+-              "${get_cmd} ${uimage}; " \
+-              "if test ${boot_fdt} = yes || test ${boot_fdt} = try; then " \
+-                      "if ${get_cmd} ${fdt_addr} ${fdt_file}; then " \
+-                              "bootm ${loadaddr} - ${fdt_addr}; " \
+-                      "else " \
+-                              "if test ${boot_fdt} = try; then " \
+-                                      "bootm; " \
+-                              "else " \
+-                                      "echo WARN: Cannot load the DT; " \
+-                              "fi; " \
+-                      "fi; " \
+-              "else " \
+-                      "bootm; " \
+               "fi;\0"
+ #define CONFIG_BOOTCOMMAND \
+@@ -191,10 +170,10 @@
+                  "else " \
+                          "if run loaduimage; then " \
+                                  "run mmcboot; " \
+-                         "else run netboot; " \
++                         "else echo WARN: Can not boot the image; " \
+                          "fi; " \
+                  "fi; " \
+-         "else run netboot; fi"
++         "fi"
+ /* Miscellaneous configurable options */
+ #define CONFIG_SYS_LONGHELP