package/uboot-omap: install image to STAGING_DIR_IMAGE
authorAlexander Couzens <lynxis@fe80.eu>
Sat, 15 Apr 2017 16:49:57 +0000 (18:49 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Mon, 24 Apr 2017 16:03:31 +0000 (18:03 +0200)
to use them later by image/Makefile to create full working sdcard images

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
package/boot/uboot-omap/Makefile

index 876d9f0574741136dc50280c636c72e48ce03ee4..17a4af42f2d9246fd4ea3ccf7f97dffa511aaa14 100644 (file)
@@ -42,4 +42,9 @@ endef
 
 UBOOT_TARGETS:=omap4_panda am335x_evm omap3_overo omap3_beagle
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)
+       $(CP) $(patsubst %,$(PKG_BUILD_DIR)/%,$(UBOOT_IMAGE)) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)/
+endef
+
 $(eval $(call BuildPackage/U-Boot))