ar71xx: add support to TP-Link Archer C59v1 and C60v1
authorHenryk Heisig <hyniu@o2.pl>
Tue, 27 Dec 2016 21:41:41 +0000 (22:41 +0100)
committerJo-Philipp Wich <jo@mein.io>
Thu, 26 Jan 2017 10:38:21 +0000 (11:38 +0100)
TP-Link Archer C59v1 is a dual-band AC1350 router, based on Qualcomm/Atheros
QCA9561+QCA9886.

Specification:

- 775/650/258 MHz (CPU/DDR/AHB)
- 128 MB of RAM (DDR2)
- 16 MB of FLASH (SPI NOR)
- 3T3R 2.4 GHz
- 2T2R 5 GHz
- 5x 10/100 Mbps Ethernet
- USB 2.0 port
- 8x LED (controled by 74HC595), 3x button
- UART header on PCB

TP-Link Archer C60v1 is a dual-band AC1350 router, based on Qualcomm/Atheros
QCA9561+QCA9886.

Specification:

- 775/650/258 MHz (CPU/DDR/AHB)
- 64 MB of RAM (DDR2)
- 8 MB of FLASH (SPI NOR)
- 3T3R 2.4 GHz
- 2T2R 5 GHz
- 5x 10/100 Mbps Ethernet
- 7x LED, 2x button
- UART header on PCB

Currently not working:
- Port LAN1 on C59, LAN4 on C60
- WiFi 5GHz (missing ath10k firmware for QCA9886 chip)
- Update from oficial web interface ( tplink-saveloader not support "product-info")

Flash instruction:
1. Set PC to fixed ip address 192.168.0.66
2. Download lede-ar71xx-generic-archer-cXX-v1-squashfs-factory.bin
and rename it to tp_recovery.bin
3. Start a tftp server with the file tp_recovery.bin in its root directory
4. Turn off the router
5. Press and hold Reset button
6. Turn on router with the reset button pressed and wait ~15 seconds
7. Release the reset button and after a short time
the firmware should be transferred from the tftp server
8. Wait ~30 second to complete recovery.

Flash instruction under U-Boot, using UART:

1. tftp 0x81000000 lede-ar71xx-...-sysupgrade.bin
2. erase 0x9f020000 +$filesize
3. cp.b $fileaddr 0x9f020000 $filesize
4. reset

Signed-off-by: Henryk Heisig <hyniu@o2.pl>
[Jo-Philipp Wich: remove duplicate ATH79_MACH_ARCHER_C59/C60_V1 entries]
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
16 files changed:
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ar71xx/base-files/etc/board.d/02_network
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-4.4
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-archer-c59-v1.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/mach-archer-c60-v1.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/image/tp-link.mk
target/linux/ar71xx/mikrotik/config-default
target/linux/ar71xx/nand/config-default
tools/firmware-utils/src/tplink-safeloader.c

index 7a7329f9653156132d7a8f3b87b28588c7f8c8ff..b1ecb0204f1575face438e854954bc5eda087981 100755 (executable)
@@ -41,6 +41,19 @@ antrouter-r1)
        ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
        ucidef_set_led_default "btc" "BTC" "$board:green:btc" "0"
        ;;
+archer-c59-v1|\
+archer-c60-v1)
+       ucidef_set_led_switch "lan" "LAN" "$board:green:lan" "switch0" "0x3C"
+       ucidef_set_led_switch "wan" "WAN" "$board:green:wan" "switch0" "0x02"
+       ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan2g" "phy1tpt"
+       ucidef_set_led_wlan "wlan5g" "WLAN5G" "$board:green:wlan5g" "phy0tpt"
+
+       case "$board" in
+       archer-c59-v1)
+               ucidef_set_led_usbdev "usb" "USB" "$board:green:usb" "1-1"
+               ;;
+       esac
+       ;;
 arduino-yun)
        ucidef_set_led_wlan "wlan" "WLAN" "arduino:blue:wlan" "phy0tpt"
        ucidef_set_led_usbdev "usb" "USB" "arduino:white:usb" "1-1.1"
index 551871e0fe1853a322826e7684e5901fcdd3c095..976440e6053345e713b2aba343b2d1dcf7af8696 100755 (executable)
@@ -196,6 +196,11 @@ ar71xx_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth1" "2:lan" "3:lan" "4:lan" "5:lan" "6@eth0" "1:wan"
                ;;
+       archer-c59-v1|\
+       archer-c60-v1)
+               ucidef_add_switch "switch0" \
+                       "0@eth0" "2:lan:4" "3:lan:3" "4:lan:2" "5:lan:1" "1:wan"
+               ;;
        arduino-yun|\
        dir-505-a1|\
        tl-wa801nd-v3)
index 4bbb93a60fa6e06cb7b9440c6c0bd82fd9ea0d55..edcf621b76283973e324d5a41eaa1709bbb667f3 100644 (file)
@@ -41,6 +41,8 @@ get_status_led() {
        ap135-020)
                status_led="ap135:green:status"
                ;;
+       archer-c59-v1|\
+       archer-c60-v1|\
        mr12|\
        mr16|\
        nbg6616|\
index a4f426e142d59a2316ddf5237a23fb54425fefbd..8693d8a0aaf8343319911dd69a2ce9fae1858116 100644 (file)
@@ -90,6 +90,8 @@ case "$FIRMWARE" in
                ath10kcal_extract "art" 20480 2116
                ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) -2)
                ;;
+       archer-c59-v1|\
+       archer-c60-v1|\
        tl-wdr6500-v2)
                ath10kcal_extract "art" 20480 2116
                ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth1/address) -2)
index ad73ec15201f5e525ddc67a4f3e0b08dbc481cd2..3ca2c0d63352f2834501bef059b184a834f60e20 100755 (executable)
@@ -454,6 +454,12 @@ ar71xx_board_detect() {
        *"Archer C5")
                name="archer-c5"
                ;;
+       *"Archer C59 v1")
+               name="archer-c59-v1"
+               ;;
+       *"Archer C60 v1")
+               name="archer-c60-v1"
+               ;;
        *"Archer C7")
                name="archer-c7"
                ;;
index e0ba5d37ff0053ad5a21c93d92053ee7d285801e..cf2aab2737b274c072caee515c62d557c6b26cfb 100755 (executable)
@@ -205,6 +205,8 @@ platform_check_image() {
        airrouter|\
        ap132|\
        ap90q|\
+       archer-c59-v1|\
+       archer-c60-v1|\
        bullet-m|\
        c-55|\
        carambola2|\
index 26de3a6393ce3c68a76767c4a082530673f05ff7..8ba0c2a18f9a114635fa486083ee712a824d3a41 100644 (file)
@@ -49,6 +49,8 @@ CONFIG_ATH79_MACH_AP152=y
 # CONFIG_ATH79_MACH_AP81 is not set
 CONFIG_ATH79_MACH_AP90Q=y
 CONFIG_ATH79_MACH_AP96=y
+CONFIG_ATH79_MACH_ARCHER_C59_V1=y
+CONFIG_ATH79_MACH_ARCHER_C60_V1=y
 CONFIG_ATH79_MACH_ARCHER_C7=y
 CONFIG_ATH79_MACH_ARDUINO_YUN=y
 CONFIG_ATH79_MACH_AW_NR580=y
@@ -272,6 +274,7 @@ CONFIG_GENERIC_SMP_IDLE_THREAD=y
 CONFIG_GENERIC_TIME_VSYSCALL=y
 CONFIG_GPIOLIB=y
 CONFIG_GPIOLIB_IRQCHIP=y
+CONFIG_GPIO_74X164=y
 CONFIG_GPIO_DEVRES=y
 # CONFIG_GPIO_LATCH is not set
 CONFIG_GPIO_NXP_74HC153=y
@@ -430,6 +433,7 @@ CONFIG_SOC_QCA956X=y
 CONFIG_SPI=y
 CONFIG_SPI_ATH79=y
 CONFIG_SPI_BITBANG=y
+CONFIG_SPI_GPIO=y
 CONFIG_SPI_MASTER=y
 # CONFIG_SPI_RB4XX is not set
 # CONFIG_SPI_VSC7385 is not set
index c3f958869e37ce0e2c01796dec79bdb528d342d4..d06ae48161452d722aa93ad0034c255e491d23bb 100644 (file)
@@ -1255,6 +1255,27 @@ config ATH79_MACH_BSB
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
 
+config ATH79_MACH_ARCHER_C59_V1
+       bool "TP-LINK Archer C59 v1 support"
+       select SOC_QCA956X
+       select ATH79_DEV_AP9X_PCI if PCI
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_USB
+       select ATH79_DEV_WMAC
+
+config ATH79_MACH_ARCHER_C60_V1
+       bool "TP-LINK Archer C60 v1 support"
+       select SOC_QCA956X
+       select ATH79_DEV_AP9X_PCI if PCI
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_WMAC
+
 config ATH79_MACH_ARCHER_C7
        bool "TP-LINK Archer C5/C7/TL-WDR4900 v2 board support"
        select SOC_QCA955X
index ac0bbc46bf73c08b0059046d4bd6cf8d37e39da4..e9d69a4d0143ed3a1c3ad6d020e3e02cd8238e94 100644 (file)
@@ -54,6 +54,8 @@ obj-$(CONFIG_ATH79_MACH_AP147)                        += mach-ap147.o
 obj-$(CONFIG_ATH79_MACH_AP152)                 += mach-ap152.o
 obj-$(CONFIG_ATH79_MACH_AP90Q)                 += mach-ap90q.o
 obj-$(CONFIG_ATH79_MACH_AP96)                  += mach-ap96.o
+obj-$(CONFIG_ATH79_MACH_ARCHER_C59_V1)         += mach-archer-c59-v1.o
+obj-$(CONFIG_ATH79_MACH_ARCHER_C60_V1)         += mach-archer-c60-v1.o
 obj-$(CONFIG_ATH79_MACH_ARCHER_C7)             += mach-archer-c7.o
 obj-$(CONFIG_ATH79_MACH_ARDUINO_YUN)           += mach-arduino-yun.o
 obj-$(CONFIG_ATH79_MACH_AW_NR580)              += mach-aw-nr580.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-archer-c59-v1.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-archer-c59-v1.c
new file mode 100644 (file)
index 0000000..28353aa
--- /dev/null
@@ -0,0 +1,223 @@
+/*
+ *  TP-Link Archer C59 v1 board support
+ *
+ *  Copyright (C) 2016 Henryk Heisig <hyniu@o2.pl>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+#include <linux/platform_device.h>
+#include <linux/ath9k_platform.h>
+#include <linux/ar8216_platform.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+#include <linux/gpio.h>
+#include <linux/init.h>
+#include <linux/spi/spi_gpio.h>
+#include <linux/spi/74x164.h>
+
+#include "common.h"
+#include "dev-m25p80.h"
+#include "machtypes.h"
+#include "pci.h"
+#include "dev-ap9x-pci.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-spi.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+
+#define ARCHER_C59_V1_KEYS_POLL_INTERVAL       20
+#define ARCHER_C59_V1_KEYS_DEBOUNCE_INTERVAL   (3 * ARCHER_C59_V1_KEYS_POLL_INTERVAL)
+
+#define ARCHER_C59_V1_GPIO_BTN_RESET           21
+#define ARCHER_C59_V1_GPIO_BTN_RFKILL          2
+#define ARCHER_C59_V1_GPIO_BTN_WPS             1
+
+#define ARCHER_C59_V1_GPIO_USB_POWER           22
+
+#define ARCHER_C59_GPIO_SHIFT_OE               16
+#define ARCHER_C59_GPIO_SHIFT_SER              17
+#define ARCHER_C59_GPIO_SHIFT_SRCLK            18
+#define ARCHER_C59_GPIO_SHIFT_SRCLR            19
+#define ARCHER_C59_GPIO_SHIFT_RCLK             20
+
+#define ARCHER_C59_74HC_GPIO_BASE              QCA956X_GPIO_COUNT
+#define ARCHER_C59_74HC_GPIO_LED_POWER         23
+#define ARCHER_C59_74HC_GPIO_LED_WLAN2         24
+#define ARCHER_C59_74HC_GPIO_LED_WLAN5         25
+#define ARCHER_C59_74HC_GPIO_LED_LAN           26
+#define ARCHER_C59_74HC_GPIO_LED_WAN_GREEN     27
+#define ARCHER_C59_74HC_GPIO_LED_WAN_AMBER     28
+#define ARCHER_C59_74HC_GPIO_LED_WPS           29
+#define ARCHER_C59_74HC_GPIO_LED_USB           30
+
+#define ARCHER_C59_V1_SSR_BIT_0                        0
+#define ARCHER_C59_V1_SSR_BIT_1                        1
+#define ARCHER_C59_V1_SSR_BIT_2                        2
+#define ARCHER_C59_V1_SSR_BIT_3                        3
+#define ARCHER_C59_V1_SSR_BIT_4                        4
+#define ARCHER_C59_V1_SSR_BIT_5                        5
+#define ARCHER_C59_V1_SSR_BIT_6                        6
+#define ARCHER_C59_V1_SSR_BIT_7                        7
+
+#define ARCHER_C59_V1_WMAC_CALDATA_OFFSET      0x1000
+#define ARCHER_C59_V1_PCI_CALDATA_OFFSET       0x5000
+
+static struct gpio_led archer_c59_v1_leds_gpio[] __initdata = {
+       {
+               .name           = "archer-c59-v1:green:power",
+               .gpio           = ARCHER_C59_74HC_GPIO_LED_POWER,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c59-v1:green:wlan2g",
+               .gpio           = ARCHER_C59_74HC_GPIO_LED_WLAN2,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c59-v1:green:wlan5g",
+               .gpio           = ARCHER_C59_74HC_GPIO_LED_WLAN5,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c59-v1:green:lan",
+               .gpio           = ARCHER_C59_74HC_GPIO_LED_LAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c59-v1:green:wan",
+               .gpio           = ARCHER_C59_74HC_GPIO_LED_WAN_GREEN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c59-v1:amber:wan",
+               .gpio           = ARCHER_C59_74HC_GPIO_LED_WAN_AMBER,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c59-v1:green:wps",
+               .gpio           = ARCHER_C59_74HC_GPIO_LED_WPS,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c59-v1:green:usb",
+               .gpio           = ARCHER_C59_74HC_GPIO_LED_USB,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button archer_c59_v1_gpio_keys[] __initdata = {
+       {
+               .desc                   = "Reset button",
+               .type                   = EV_KEY,
+               .code                   = KEY_RESTART,
+               .debounce_interval      = ARCHER_C59_V1_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = ARCHER_C59_V1_GPIO_BTN_RESET,
+               .active_low             = 1,
+       },
+       {
+               .desc                   = "RFKILL button",
+               .type                   = EV_KEY,
+               .code                   = KEY_RFKILL,
+               .debounce_interval      = ARCHER_C59_V1_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = ARCHER_C59_V1_GPIO_BTN_RFKILL,
+               .active_low             = 1,
+       },
+       {
+               .desc                   = "WPS button",
+               .type                   = EV_KEY,
+               .code                   = KEY_WPS_BUTTON,
+               .debounce_interval      = ARCHER_C59_V1_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = ARCHER_C59_V1_GPIO_BTN_WPS,
+               .active_low             = 1,
+       },
+};
+
+static struct spi_gpio_platform_data archer_c59_v1_spi_data = {
+       .sck            = ARCHER_C59_GPIO_SHIFT_SRCLK,
+       .miso           = SPI_GPIO_NO_MISO,
+       .mosi           = ARCHER_C59_GPIO_SHIFT_SER,
+       .num_chipselect = 1,
+};
+
+static u8 archer_c59_v1_ssr_initdata[] __initdata = {
+       BIT(ARCHER_C59_V1_SSR_BIT_7) |
+       BIT(ARCHER_C59_V1_SSR_BIT_6) |
+       BIT(ARCHER_C59_V1_SSR_BIT_5) |
+       BIT(ARCHER_C59_V1_SSR_BIT_4) |
+       BIT(ARCHER_C59_V1_SSR_BIT_3) |
+       BIT(ARCHER_C59_V1_SSR_BIT_2) |
+       BIT(ARCHER_C59_V1_SSR_BIT_1)
+};
+
+static struct gen_74x164_chip_platform_data archer_c59_v1_ssr_data = {
+       .base = ARCHER_C59_74HC_GPIO_BASE,
+       .num_registers = ARRAY_SIZE(archer_c59_v1_ssr_initdata),
+       .init_data = archer_c59_v1_ssr_initdata,
+};
+
+static struct platform_device archer_c59_v1_spi_device = {
+       .name           = "spi_gpio",
+       .id             = 1,
+       .dev = {
+               .platform_data = &archer_c59_v1_spi_data,
+       },
+};
+
+static struct spi_board_info archer_c59_v1_spi_info[] = {
+       {
+               .bus_num        = 1,
+               .chip_select    = 0,
+               .max_speed_hz   = 10000000,
+               .modalias       = "74x164",
+               .platform_data  =  &archer_c59_v1_ssr_data,
+               .controller_data = (void *) ARCHER_C59_GPIO_SHIFT_RCLK,
+       },
+};
+
+static void __init archer_c59_v1_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f010008);
+       u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+       ath79_register_m25p80(NULL);
+       spi_register_board_info(archer_c59_v1_spi_info,
+                          ARRAY_SIZE(archer_c59_v1_spi_info));
+       platform_device_register(&archer_c59_v1_spi_device);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(archer_c59_v1_leds_gpio),
+                               archer_c59_v1_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, ARCHER_C59_V1_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(archer_c59_v1_gpio_keys),
+                                       archer_c59_v1_gpio_keys);
+
+       ath79_register_mdio(1, 0x0);
+
+       ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac, 0);
+       ath79_eth1_data.speed = SPEED_1000;
+       ath79_eth1_data.duplex = DUPLEX_FULL;
+       ath79_eth1_data.phy_mask = BIT(4);
+       ath79_register_eth(1);
+
+       ath79_register_wmac(art + ARCHER_C59_V1_WMAC_CALDATA_OFFSET, mac);
+       ap91_pci_init(art + ARCHER_C59_V1_PCI_CALDATA_OFFSET, NULL);
+
+
+       ath79_register_usb();
+       gpio_request_one(ARCHER_C59_V1_GPIO_USB_POWER,
+                        GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
+                        "USB power");
+       gpio_request_one(ARCHER_C59_GPIO_SHIFT_OE,
+                        GPIOF_OUT_INIT_LOW | GPIOF_EXPORT_DIR_FIXED,
+                        "LED control");
+       gpio_request_one(ARCHER_C59_GPIO_SHIFT_SRCLR,
+                        GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
+                        "LED reset");
+}
+
+MIPS_MACHINE(ATH79_MACH_ARCHER_C59_V1, "ARCHER-C59-V1",
+       "TP-LINK Archer C59 v1", archer_c59_v1_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-archer-c60-v1.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-archer-c60-v1.c
new file mode 100644 (file)
index 0000000..78186f0
--- /dev/null
@@ -0,0 +1,135 @@
+/*
+ *  TP-Link Archer C60 v1 board support
+ *
+ *  Copyright (C) 2016 Henryk Heisig <hyniu@o2.pl>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+#include <linux/platform_device.h>
+#include <linux/ath9k_platform.h>
+#include <linux/ar8216_platform.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+#include <linux/gpio.h>
+
+#include "common.h"
+#include "dev-m25p80.h"
+#include "machtypes.h"
+#include "pci.h"
+#include "dev-ap9x-pci.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-spi.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+
+#define ARCHER_C60_V1_GPIO_LED_LAN             2
+#define ARCHER_C60_V1_GPIO_LED_POWER           16
+#define ARCHER_C60_V1_GPIO_LED_WLAN2           17
+#define ARCHER_C60_V1_GPIO_LED_WLAN5           18
+#define ARCHER_C60_V1_GPIO_LED_WPS             19
+#define ARCHER_C60_V1_GPIO_LED_WAN_GREEN       20
+#define ARCHER_C60_V1_GPIO_LED_WAN_AMBER       22
+
+
+#define ARCHER_C60_V1_KEYS_POLL_INTERVAL       20
+#define ARCHER_C60_V1_KEYS_DEBOUNCE_INTERVAL   (3 * ARCHER_C60_V1_KEYS_POLL_INTERVAL)
+
+#define ARCHER_C60_V1_GPIO_BTN_RESET           21
+#define ARCHER_C60_V1_GPIO_BTN_RFKILL          1
+
+
+
+#define ARCHER_C60_V1_WMAC_CALDATA_OFFSET      0x1000
+#define ARCHER_C60_V1_PCI_CALDATA_OFFSET       0x5000
+
+static struct gpio_led archer_c60_v1_leds_gpio[] __initdata = {
+       {
+               .name           = "archer-c60-v1:green:power",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_POWER,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c60-v1:green:wlan2g",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_WLAN2,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c60-v1:green:wlan5g",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_WLAN5,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c60-v1:green:lan",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_LAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c60-v1:green:wan",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_WAN_GREEN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c60-v1:amber:wan",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_WAN_AMBER,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c60-v1:green:wps",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_WPS,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button archer_c60_v1_gpio_keys[] __initdata = {
+       {
+               .desc                   = "Reset button",
+               .type                   = EV_KEY,
+               .code                   = KEY_RESTART,
+               .debounce_interval      = ARCHER_C60_V1_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = ARCHER_C60_V1_GPIO_BTN_RESET,
+               .active_low             = 1,
+       },
+       {
+               .desc                   = "RFKILL button",
+               .type                   = EV_KEY,
+               .code                   = KEY_RFKILL,
+               .debounce_interval      = ARCHER_C60_V1_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = ARCHER_C60_V1_GPIO_BTN_RFKILL,
+               .active_low             = 1,
+       },
+};
+
+static void __init archer_c60_v1_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f010008);
+       u8 *art = (u8 *) KSEG1ADDR(0x1f7f0000);
+
+       ath79_register_m25p80(NULL);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(archer_c60_v1_leds_gpio),
+                               archer_c60_v1_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, ARCHER_C60_V1_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(archer_c60_v1_gpio_keys),
+                                       archer_c60_v1_gpio_keys);
+
+       ath79_setup_qca956x_eth_cfg(QCA956X_ETH_CFG_SW_PHY_SWAP |
+                                  QCA956X_ETH_CFG_SW_PHY_ADDR_SWAP);
+       ath79_register_mdio(1, 0x0);
+
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac, 0);
+
+       ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+       ath79_eth1_data.speed = SPEED_1000;
+       ath79_eth1_data.duplex = DUPLEX_FULL;
+       ath79_register_eth(1);
+
+       ath79_register_wmac(art + ARCHER_C60_V1_WMAC_CALDATA_OFFSET, mac);
+       ap91_pci_init(art + ARCHER_C60_V1_PCI_CALDATA_OFFSET, NULL);
+}
+
+MIPS_MACHINE(ATH79_MACH_ARCHER_C60_V1, "ARCHER-C60-V1",
+       "TP-LINK Archer C60 v1", archer_c60_v1_setup);
index 857d0eee89f13d799f5767f18078318f9caea89a..12e81dbe5be4241df44679adf25b41164c052a02 100644 (file)
@@ -38,6 +38,8 @@ enum ath79_mach_type {
        ATH79_MACH_AP90Q,                       /* YunCore AP90Q */
        ATH79_MACH_AP96,                        /* Atheros AP96 */
        ATH79_MACH_ARCHER_C5,                   /* TP-LINK Archer C5 board */
+       ATH79_MACH_ARCHER_C59_V1,               /* TP-LINK Archer C59 V1 board */
+       ATH79_MACH_ARCHER_C60_V1,               /* TP-LINK Archer C60 V1 board */
        ATH79_MACH_ARCHER_C7,                   /* TP-LINK Archer C7 board */
        ATH79_MACH_ARCHER_C7_V2,                /* TP-LINK Archer C7 V2 board */
        ATH79_MACH_ARDUINO_YUN,                 /* Yun */
index 480d9ad39dabca0839bd66d307fe3693e248be36..d163ffb0fe89be90c1d692fe3aa25ef6b63f696b 100644 (file)
@@ -45,6 +45,15 @@ define Build/mktplinkfw-kernel
        @mv $@.new $@
 endef
 
+define Build/uImageArcher
+       mkimage -A $(LINUX_KARCH) \
+               -O linux -T kernel \
+               -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+               -n '$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION)' -d $@ $@.new
+       @mv $@.new $@
+endef
+
+
 define Device/tplink
   TPLINK_HWREV := 0x1
   TPLINK_HEADER_VERSION := 1
@@ -95,6 +104,36 @@ $(Device/tplink)
   IMAGE_SIZE := 15872k
 endef
 
+define Device/archer-c59-v1
+  DEVICE_TITLE := TP-LINK Archer C59 v1
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k
+  BOARDNAME := ARCHER-C59-V1
+  TPLINK_BOARD_NAME := ARCHER-C59-V1
+  DEVICE_PROFILE := ARCHERC59V1
+  IMAGE_SIZE := 14528k
+  KERNEL := kernel-bin | patch-cmdline | lzma | uImageArcher lzma
+  IMAGES := sysupgrade.bin factory.bin
+  IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade
+  IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+  MTDPARTS := spi0.0:64k(u-boot)ro,64k(mac)ro,1536k(kernel),12992k(rootfs),1664k(tplink)ro,64k(art)ro,14528k@0x20000(firmware)
+endef
+TARGET_DEVICES += archer-c59-v1
+
+define Device/archer-c60-v1
+  DEVICE_TITLE := TP-LINK Archer C60 v1
+  DEVICE_PACKAGES := kmod-ath10k
+  BOARDNAME := ARCHER-C60-V1
+  TPLINK_BOARD_NAME := ARCHER-C60-V1
+  DEVICE_PROFILE := ARCHERC60V1
+  IMAGE_SIZE := 7936k
+  KERNEL := kernel-bin | patch-cmdline | lzma | uImageArcher lzma
+  IMAGES := sysupgrade.bin factory.bin
+  IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade
+  IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+  MTDPARTS := spi0.0:64k(u-boot)ro,64k(mac)ro,1344k(kernel),6592k(rootfs),64k(tplink)ro,64k(art)ro,7936k@0x20000(firmware)
+endef
+TARGET_DEVICES += archer-c60-v1
+
 define Device/cpe510-520
   DEVICE_TITLE := TP-LINK CPE510/520
   DEVICE_PACKAGES := rssileds
index 44ea327fb1af2cef210e24d529826d315929a72c..6440bc499cd54ea3e5142c35234c3df83347d6e5 100644 (file)
@@ -15,6 +15,8 @@
 # CONFIG_ATH79_MACH_AP152 is not set
 # CONFIG_ATH79_MACH_AP90Q is not set
 # CONFIG_ATH79_MACH_AP96 is not set
+# CONFIG_ATH79_MACH_ARCHER_C59_V1 is not set
+# CONFIG_ATH79_MACH_ARCHER_C60_V1 is not set
 # CONFIG_ATH79_MACH_ARCHER_C7 is not set
 # CONFIG_ATH79_MACH_ARDUINO_YUN is not set
 # CONFIG_ATH79_MACH_AW_NR580 is not set
index 515266b0f8386fa44a3c872ff7356d5a7bfb8dd2..3fcb3e631b770e9371b5d68ed10c2d4666ae43b6 100644 (file)
@@ -8,6 +8,8 @@
 # CONFIG_ATH79_MACH_AP136 is not set
 # CONFIG_ATH79_MACH_AP147 is not set
 # CONFIG_ATH79_MACH_AP96 is not set
+# CONFIG_ATH79_MACH_ARCHER_C59_V1 is not set
+# CONFIG_ATH79_MACH_ARCHER_C60_V1 is not set
 # CONFIG_ATH79_MACH_ARCHER_C7 is not set
 # CONFIG_ATH79_MACH_AW_NR580 is not set
 # CONFIG_ATH79_MACH_CAP324 is not set
index 89a6787b22974bde2b7d17533988124268b2b8b8..a1dc987fb54559ecb9903099d110ec244f78576f 100644 (file)
@@ -293,6 +293,77 @@ static struct device_info boards[] = {
                .last_sysupgrade_partition = "file-system"
        },
 
+       /** Firmware layout for the C59v1 */
+       {
+               .id     = "ARCHER-C59-V1",
+               .vendor = "",
+               .support_list =
+                       "SupportList:\r\n"
+                       "{product_name:Archer C59,product_ver:1.0.0,special_id:00000000}\r\n"
+                       "{product_name:Archer C59,product_ver:1.0.0,special_id:45550000}\r\n"
+                       "{product_name:Archer C59,product_ver:1.0.0,special_id:55530000}\r\n",
+               .support_trail = '\x00',
+
+               .partitions = {
+                       {"fs-uboot", 0x00000, 0x10000},
+                       {"default-mac", 0x10000, 0x00200},
+                       {"pin", 0x10200, 0x00200},
+                       {"device-id", 0x10400, 0x00100},
+                       {"product-info", 0x10500, 0x0fb00},
+                       {"os-image", 0x20000, 0x180000},
+                       {"file-system", 0x1a0000, 0xcb0000},
+                       {"partition-table", 0xe50000, 0x10000},
+                       {"soft-version", 0xe60000, 0x10000},
+                       {"support-list", 0xe70000, 0x10000},
+                       {"profile", 0xe80000, 0x10000},
+                       {"default-config", 0xe90000, 0x10000},
+                       {"user-config", 0xea0000, 0x40000},
+                       {"usb-config", 0xee0000, 0x10000},
+                       {"certificate", 0xef0000, 0x10000},
+                       {"qos-db", 0xf00000, 0x40000},
+                       {"log", 0xfe0000, 0x10000},
+                       {"radio", 0xff0000, 0x10000},
+                       {NULL, 0, 0}
+               },
+
+               .first_sysupgrade_partition = "os-image",
+               .last_sysupgrade_partition = "file-system",
+       },
+
+       /** Firmware layout for the C60v1 */
+       {
+               .id     = "ARCHER-C60-V1",
+               .vendor = "",
+               .support_list =
+                       "SupportList:\r\n"
+                       "{product_name:Archer C60,product_ver:1.0.0,special_id:00000000}\r\n"
+                       "{product_name:Archer C60,product_ver:1.0.0,special_id:45550000}\r\n"
+                       "{product_name:Archer C60,product_ver:1.0.0,special_id:55530000}\r\n",
+               .support_trail = '\x00',
+
+               .partitions = {
+                       {"fs-uboot", 0x00000, 0x10000},
+                       {"default-mac", 0x10000, 0x00200},
+                       {"pin", 0x10200, 0x00200},
+                       {"product-info", 0x10400, 0x00100},
+                       {"partition-table", 0x10500, 0x00800},
+                       {"soft-version", 0x11300, 0x00200},
+                       {"support-list", 0x11500, 0x00100},
+                       {"device-id", 0x11600, 0x00100},
+                       {"profile", 0x11700, 0x03900},
+                       {"default-config", 0x15000, 0x04000},
+                       {"user-config", 0x19000, 0x04000},
+                       {"os-image", 0x20000, 0x150000},
+                       {"file-system", 0x170000, 0x678000},
+                       {"certyficate", 0x7e8000, 0x08000},
+                       {"radio", 0x7f0000, 0x10000},
+                       {NULL, 0, 0}
+               },
+
+               .first_sysupgrade_partition = "os-image",
+               .last_sysupgrade_partition = "file-system",
+       },
+
        /** Firmware layout for the C9 */
        {
                .id = "ARCHERC9",