broadcom-wl: fix build after IRQF_SAMPLE_RANDOM flag removal (#12248)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 4 Oct 2012 12:36:45 +0000 (12:36 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 4 Oct 2012 12:36:45 +0000 (12:36 +0000)
SVN-Revision: 33617

package/broadcom-wl/Makefile
package/broadcom-wl/patches/010-remove_irqf_samble_random.patch [new file with mode: 0644]

index a2bd679d16a92d2afa3bc660778c6cf97801410b..1a7da0f89d4ee8f999d15c5211cab0fd9f52699c 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=broadcom-wl
 PKG_VERSION:=5.10.56.27.3
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)_$(ARCH).tar.bz2
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
diff --git a/package/broadcom-wl/patches/010-remove_irqf_samble_random.patch b/package/broadcom-wl/patches/010-remove_irqf_samble_random.patch
new file mode 100644 (file)
index 0000000..27b132d
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/driver/wl_linux.c        2012-09-26 20:51:48.099454971 -0400
++++ b/driver/wl_linux.c        2012-09-26 20:53:24.115453441 -0400
+@@ -691,7 +691,7 @@
+       if (wl->bustype != JTAG_BUS)
+ #endif        /* BCMJTAG */
+       {
+-              if (request_irq(irq, wl_isr, IRQF_SHARED|IRQF_SAMPLE_RANDOM, dev->name, wl)) {
++              if (request_irq(irq, wl_isr, IRQF_SHARED, dev->name, wl)) {
+                       WL_ERROR(("wl%d: request_irq() failed\n", unit));
+                       goto fail;
+               }