openssl: update to 1.0.1b
authorFlorian Fainelli <florian@openwrt.org>
Wed, 2 May 2012 15:40:32 +0000 (15:40 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 2 May 2012 15:40:32 +0000 (15:40 +0000)
SVN-Revision: 31551

package/openssl/Makefile
package/openssl/patches/210-no-OPENSSL_ia32cap_P.patch [deleted file]

index b9b9b3102a2276e942d39e62f2cefa69f52438dd..923096cfc4cf836cfd2c4864ea7cb2a9a1e44891 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=1.0.1a
+PKG_VERSION:=1.0.1b
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
        ftp://ftp.webmonster.de/pub/openssl/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=a0104320c0997cd33e18b8ea798609d1
+PKG_MD5SUM:=a1da58ce63baef3812004714fa302c47
 
 PKG_BUILD_DEPENDS:=ocf-crypto-headers
 PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE
diff --git a/package/openssl/patches/210-no-OPENSSL_ia32cap_P.patch b/package/openssl/patches/210-no-OPENSSL_ia32cap_P.patch
deleted file mode 100644 (file)
index 6ddf009..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/crypto/evp/e_rc4_hmac_md5.c
-+++ b/crypto/evp/e_rc4_hmac_md5.c
-@@ -289,8 +289,6 @@ static EVP_CIPHER r4_hmac_md5_cipher=
- const EVP_CIPHER *EVP_rc4_hmac_md5(void)
-       {
--      extern unsigned int OPENSSL_ia32cap_P[];
--      /* RC4_CHAR flag ------------vvvvv */
--      return(OPENSSL_ia32cap_P[0]&(1<<20) ? NULL : &r4_hmac_md5_cipher);
-+      return(&r4_hmac_md5_cipher);
-       }
- #endif