ramips: add support for the ARC FreeStation5 board, also fix WCR-150GN network setup...
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 29 Mar 2012 16:03:04 +0000 (16:03 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 29 Mar 2012 16:03:04 +0000 (16:03 +0000)
SVN-Revision: 31144

12 files changed:
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/network
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-freestation5.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-3.2
target/linux/ramips/rt305x/profiles/freestation5.mk [new file with mode: 0644]

index 7bd58d5facb9f8b7b64bed8093f4720124af8bef..62788cde48d7cdc60941e5f6b61f2bbb3b5f19c7 100644 (file)
@@ -53,6 +53,7 @@ case "$FIRMWARE" in
        bc2 | \
        esr-9753 | \
        fonera20n | \
+       freestation5 | \
        hw550-3g | \
        mofi3500-3gn | \
        pwh2004 | \
index a17fad8e98266422d03bf17058c25d8c524b4f19..dc2221f1e70a66e743ca022a0594f56cfa14fdf9 100755 (executable)
@@ -54,8 +54,9 @@ ramips_setup_interfaces()
                ucidef_add_switch_vlan "switch0" "2" "4 8t"
                ;;
 
+       freestation5 | \
        wcr-150gn)
-               ucidef_set_interface_lan_wan "eth0.2" "eth0.1"
+               ucidef_set_interfaces_lan_wan "eth0.2" "eth0.1"
                ;;
 
        wli-tx4-ag300n)
index 90c327a2ed43d056e509f687eb97ff222fffa31a..f523d690d47418f9b63fa6900e423bc8b5640e60 100644 (file)
@@ -10,6 +10,7 @@ preinit_set_mac_address() {
        case $(ramips_board_name) in
        bc2 |\
        esr-9753 |\
+       freestation5 |\
        nw718 |\
        rt-n56u |\
        sl-r7205)
index 6e1da23040bf605c635ed956efb5e1544ee189dd..1298ebda932806b49faaa838696b2487df4c9f9d 100755 (executable)
@@ -50,6 +50,9 @@ ramips_board_name() {
        *"Allnet ALL0256N")
                name="all0256n"
                ;;
+       *"ARC FreeStation5")
+               name="freestation5"
+               ;;
        *"Argus ATP-52B")
                name="argus-atp52b"
                ;;
index 4d0bb19c77172b87f3bf0cb7c8475a9eb6808cbf..7f500d9796fdc2a5567b3397ad2ea358caf46ab4 100755 (executable)
@@ -21,6 +21,7 @@ platform_check_image() {
        dir-600-b2 | \
        esr-9753 | \
        fonera20n | \
+       freestation5 | \
        hw550-3g | \
        mofi3500-3gn | \
        nbg-419n | \
index bce51cd071691612533fa1b0443a170fc5abe6e5..c2ec146c9773f7aacbb66b7e93679ebe8f6c8427 100644 (file)
@@ -37,6 +37,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_ESR_9753,           /* Senao / EnGenius ESR-9753*/
        RAMIPS_MACH_F5D8235_V2,         /* Belkin F5D8235 v2 */
        RAMIPS_MACH_FONERA20N,          /* La Fonera 2.0N */
+       RAMIPS_MACH_FREESTATION5,       /* ARC Freestation5 */
        RAMIPS_MACH_HW550_3G,           /* Aztech HW550-3G */
        RAMIPS_MACH_MOFI3500_3GN,       /* MoFi Network MOFI3500-3GN */
        RAMIPS_MACH_NBG_419N,           /* ZyXEL NBG-419N */
index 6c5a62f507583b92c7ca66b1d62a5e90aebcf90d..ef4ddf40978ac20fe19a883539aa6c7e75a25503 100644 (file)
@@ -66,6 +66,9 @@ config RT305X_MACH_FONERA20N
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_FREESTATION5
+       bool "ARC FreeStation5"
+
 config RT305X_MACH_MOFI3500_3GN
        bool "MoFi Network MOFI3500-3GN support"
        select RALINK_DEV_GPIO_BUTTONS
index db3c26210d1a1c478133576137cb5179035617b0..03369365056fd2ad321f5ecb8e5b1258dfdc409f 100644 (file)
@@ -18,6 +18,7 @@ obj-$(CONFIG_RT305X_MACH_DIR_300_REVB)        += mach-dir-300-revb.o
 obj-$(CONFIG_RT305X_MACH_ESR_9753)     += mach-esr-9753.o
 obj-$(CONFIG_RT305X_MACH_F5D8235_V2)    += mach-f5d8235-v2.o
 obj-$(CONFIG_RT305X_MACH_FONERA20N)    += mach-fonera20n.o
+obj-$(CONFIG_RT305X_MACH_FREESTATION5)  += mach-freestation5.o
 obj-$(CONFIG_RT305X_MACH_HW550_3G)     += mach-hw550-3g.o
 obj-$(CONFIG_RT305X_MACH_MOFI3500_3GN) += mach-mofi3500-3gn.o
 obj-$(CONFIG_RT305X_MACH_NBG_419N)     += mach-nbg-419n.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-freestation5.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-freestation5.c
new file mode 100644 (file)
index 0000000..b868244
--- /dev/null
@@ -0,0 +1,34 @@
+/*
+ *  ARC FreeStation2/5 board support
+ *
+ *  Copyright (C) 2009 John Crispin <blogic@openwrt.org>
+ *  Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2012 Pau Escrich <p4u@dabax.net>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+static void __init freestation5_init(void)
+{
+       rt305x_register_flash(0);
+
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_WLLLL;
+       rt305x_register_ethernet();
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+       rt305x_register_usb();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_FREESTATION5, "FREESTATION5", "ARC FreeStation5",
+            freestation5_init);
index a4d526df18e987806298004cb62239234c030f4e..0c37f7e3524ede66dc0ef5b79698e12f9b1df9cf 100644 (file)
@@ -331,6 +331,10 @@ define Image/Build/Profile/FONERA20N
        $(call Image/Build/Template/$(fs_squash)/$(1),FONERA20N)
 endef
 
+define Image/Build/Profile/FREESTATION5
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,freestation5,FREESTATION5,ttyS1,115200,phys)
+endef
+
 define Image/Build/Profile/MOFI35003GN
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,mofi3500-3gn,MOFI3500-3GN,ttyS1,57600,phys)
 endef
@@ -414,6 +418,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/F5D8235V2,$(1))
        $(call Image/Build/Profile/RTN10PLUS,$(1))
        $(call Image/Build/Profile/FONERA20N,$(1))
+       $(call Image/Build/Profile/FREESTATION5,$(1))
        $(call Image/Build/Profile/HW5503G,$(1))
        $(call Image/Build/Profile/MOFI35003GN,$(1))
        $(call Image/Build/Profile/NBG419N,$(1))
index 4c928a4cdb3b8bfbd00ae59ad8fa4bce2adcec35..993cc5acdda54f910669d97ece43e062fdb9a3c4 100644 (file)
@@ -100,6 +100,7 @@ CONFIG_RT305X_MACH_DIR_300_REVB=y
 CONFIG_RT305X_MACH_ESR_9753=y
 CONFIG_RT305X_MACH_F5D8235_V2=y
 CONFIG_RT305X_MACH_FONERA20N=y
+CONFIG_RT305X_MACH_FREESTATION5=y
 CONFIG_RT305X_MACH_HW550_3G=y
 CONFIG_RT305X_MACH_MOFI3500_3GN=y
 CONFIG_RT305X_MACH_NBG_419N=y
diff --git a/target/linux/ramips/rt305x/profiles/freestation5.mk b/target/linux/ramips/rt305x/profiles/freestation5.mk
new file mode 100644 (file)
index 0000000..6da1e68
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/FREESTATION5
+       NAME:=FreeStation5
+       PACKAGES:=\
+                kmod-usb-rt305x-dwc_otg kmod-rt2500-usb kmod-rt2800-usb kmod-rt2x00-usb
+endef
+
+define Profile/FREESTATION5/Description
+       Package set for ARC Flex FreeStation5
+endef
+
+$(eval $(call Profile,FREESTATION5))