ath9k: always select relay support, not just when debugfs is enabled - fixes an unres...
authorFelix Fietkau <nbd@openwrt.org>
Sat, 14 Mar 2015 12:12:25 +0000 (12:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 14 Mar 2015 12:12:25 +0000 (12:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 44754

package/kernel/mac80211/Makefile

index 6623c5ad39214909cc2b00e1372075c23eef472f..a18ccdc02f1b08202de418dbb9ce77fa6cd11665 100644 (file)
@@ -92,7 +92,6 @@ define KernelPackage/mac80211/config
        config PACKAGE_MAC80211_DEBUGFS
                bool "Export mac80211 internals in DebugFS"
                select KERNEL_DEBUG_FS
-               select KERNEL_RELAY if PACKAGE_kmod-ath9k-common
                default y
                help
                  Select this to see extensive information about
@@ -561,7 +560,7 @@ define KernelPackage/ath9k-common
   $(call KernelPackage/mac80211/Default)
   TITLE:=Atheros 802.11n wireless devices (common code for ath9k and ath9k_htc)
   URL:=http://linuxwireless.org/en/users/Drivers/ath9k
-  DEPENDS+= @PCI_SUPPORT||USB_SUPPORT||TARGET_ar71xx +kmod-ath +@DRIVER_11N_SUPPORT
+  DEPENDS+= @PCI_SUPPORT||USB_SUPPORT||TARGET_ar71xx +kmod-ath +@DRIVER_11N_SUPPORT +@KERNEL_RELAY
   FILES:= \
        $(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k_common.ko \
        $(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k_hw.ko