ar71xx: enable profile sorting in preparation for adding device profiles
authorFelix Fietkau <nbd@nbd.name>
Mon, 23 May 2016 15:51:19 +0000 (17:51 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 7 Jun 2016 06:58:41 +0000 (08:58 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/ar71xx/generic/profiles/00-default.mk
target/linux/ar71xx/generic/profiles/01-minimal.mk
target/linux/ar71xx/generic/profiles/02-ath5k.mk
target/linux/ar71xx/mikrotik/profiles/01-minimal.mk
target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk

index 36c4aa61b9378cdcb02849f0c0be506046b2c581..bf0f3fa5e63b5e5b2b4920251154d275c268ac0a 100644 (file)
@@ -9,6 +9,7 @@ define Profile/Default
        NAME:=Default Profile (all drivers)
        PACKAGES:= \
                kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+       PRIORITY := 1
 endef
 
 define Profile/Default/Description
index dfaa3b0b37cde02cffd870bba3548a2231707668..54e6c6ddfbb068dcaa4a41819ae40f3e007f39af 100644 (file)
@@ -8,6 +8,7 @@
 define Profile/Minimal
        NAME:=Minimal Profile (no drivers)
        PACKAGES:=-kmod-ath9k -wpad-mini
+       PRIORITY := 2
 endef
 
 define Profile/Minimal/Description
index 78203497f3d4f059a4ef010398f63ff1753fb32f..baa92b339185e5e778716965e755d8348c9dcc55 100644 (file)
@@ -8,6 +8,7 @@
 define Profile/ath5k
        NAME:=Atheros 802.11abg WiFi (ath5k)
        PACKAGES:=kmod-ath5k -kmod-ath9k
+       PRIORITY := 3
 endef
 
 define Profile/ath5k/Description
index 3651c88ab2d49356e4c29d077ebc862be8ee9e16..a334977d488c4813086a29b7afc3a26402be17d5 100644 (file)
@@ -8,6 +8,7 @@
 define Profile/DefaultNoWifi
        NAME:=Default Profile (no WiFi)
        PACKAGES:=
+       PRIORITY := 2
 endef
 
 define Profile/DefaultNoWifi/Description
index a291ff68aeb54477d5f0f34306e1f06ec305b6f6..fa304b7d4c3cd85f1270b25f63e66d97077ab437 100644 (file)
@@ -8,6 +8,7 @@
 define Profile/Ath5k
        NAME:=Atheros WiFi (ath5k)
        PACKAGES:=kmod-ath5k -kmod-ath9k
+       PRIORITY := 3
 endef
 
 define Profile/Ath5k/Description