uboot-sunxi: refresh patches
authorZoltan HERPAI <wigyori@uid0.hu>
Wed, 21 Mar 2018 15:59:46 +0000 (16:59 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Wed, 21 Mar 2018 16:08:35 +0000 (17:08 +0100)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/boot/uboot-sunxi/patches/003-add-theobroma-a31-pangolin.patch
package/boot/uboot-sunxi/patches/091-sun6i-sync-PLL1-multdiv-with-Boot1.patch
package/boot/uboot-sunxi/patches/101-sun6i-support-console-on-UART2.patch
package/boot/uboot-sunxi/patches/102-sunxi-make_CONS_INDEX-configurable.patch
package/boot/uboot-sunxi/patches/220-add-sunxi50i-nanopi-neo-plus2.patch
package/boot/uboot-sunxi/patches/320-sunxi-Add-support-for-Orange-Pi-R1.patch
package/boot/uboot-sunxi/patches/400-ARM-dts-orange-pi-zero-plus.patch

index 2fce04828c4745a9d3ee8850e2d795c7efb40f2d..4458d514c242c524e22a08e3e1dc5b76da8df9b9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
-@@ -254,6 +254,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
+@@ -261,6 +261,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
        sun6i-a31-m9.dtb \
        sun6i-a31-mele-a1000g-quad.dtb \
        sun6i-a31-mixtile-loftq.dtb \
        sun6i-a31-m9.dtb \
        sun6i-a31-mele-a1000g-quad.dtb \
        sun6i-a31-mixtile-loftq.dtb \
 +CONFIG_SUNXI_SPI=y
 --- a/arch/arm/mach-sunxi/Kconfig
 +++ b/arch/arm/mach-sunxi/Kconfig
 +CONFIG_SUNXI_SPI=y
 --- a/arch/arm/mach-sunxi/Kconfig
 +++ b/arch/arm/mach-sunxi/Kconfig
-@@ -746,6 +746,14 @@ config VIDEO_LCD_PANEL_I2C_SCL
+@@ -752,6 +752,14 @@ config VIDEO_LCD_PANEL_I2C_SCL
        Set the SCL pin for the LCD i2c interface. This takes a string in the
        format understood by sunxi_name_to_gpio, e.g. PH1 for pin 1 of port H.
  
        Set the SCL pin for the LCD i2c interface. This takes a string in the
        format understood by sunxi_name_to_gpio, e.g. PH1 for pin 1 of port H.
  
index 40d79878ad66f4261e69ac40d39046fd3de25af8..cf41c4f1f12cfa942b335b688ddea5adb6c80d43 100644 (file)
@@ -14,7 +14,7 @@ More specifically, the following settings are now used:
 
 --- a/arch/arm/mach-sunxi/clock_sun6i.c
 +++ b/arch/arm/mach-sunxi/clock_sun6i.c
 
 --- a/arch/arm/mach-sunxi/clock_sun6i.c
 +++ b/arch/arm/mach-sunxi/clock_sun6i.c
-@@ -107,11 +107,12 @@ void clock_set_pll1(unsigned int clk)
+@@ -113,11 +113,12 @@ void clock_set_pll1(unsigned int clk)
        struct sunxi_ccm_reg * const ccm =
                (struct sunxi_ccm_reg *)SUNXI_CCM_BASE;
        const int p = 0;
        struct sunxi_ccm_reg * const ccm =
                (struct sunxi_ccm_reg *)SUNXI_CCM_BASE;
        const int p = 0;
index d140f2d53868de2305a55ffc17a63c10bb076559..c1ba07eec58ec40cfef7e54f091a80e7b681e67e 100644 (file)
@@ -6,7 +6,7 @@ Subject: ARM: sun6i: Support console on UART2 (GPG6/GPG7)
 
 --- a/arch/arm/mach-sunxi/board.c
 +++ b/arch/arm/mach-sunxi/board.c
 
 --- a/arch/arm/mach-sunxi/board.c
 +++ b/arch/arm/mach-sunxi/board.c
-@@ -126,6 +126,10 @@ static int gpio_init(void)
+@@ -124,6 +124,10 @@ static int gpio_init(void)
        sunxi_gpio_set_cfgpin(SUNXI_GPG(3), SUN5I_GPG_UART1);
        sunxi_gpio_set_cfgpin(SUNXI_GPG(4), SUN5I_GPG_UART1);
        sunxi_gpio_set_pull(SUNXI_GPG(4), SUNXI_GPIO_PULL_UP);
        sunxi_gpio_set_cfgpin(SUNXI_GPG(3), SUN5I_GPG_UART1);
        sunxi_gpio_set_cfgpin(SUNXI_GPG(4), SUN5I_GPG_UART1);
        sunxi_gpio_set_pull(SUNXI_GPG(4), SUNXI_GPIO_PULL_UP);
@@ -19,7 +19,7 @@ Subject: ARM: sun6i: Support console on UART2 (GPG6/GPG7)
        sunxi_gpio_set_cfgpin(SUNXI_GPB(1), SUN8I_GPB_UART2);
 --- a/include/configs/sunxi-common.h
 +++ b/include/configs/sunxi-common.h
        sunxi_gpio_set_cfgpin(SUNXI_GPB(1), SUN8I_GPB_UART2);
 --- a/include/configs/sunxi-common.h
 +++ b/include/configs/sunxi-common.h
-@@ -259,6 +259,8 @@ extern int soft_i2c_gpio_scl;
+@@ -256,6 +256,8 @@ extern int soft_i2c_gpio_scl;
  #endif
  #elif CONFIG_CONS_INDEX == 2 && defined(CONFIG_MACH_SUN5I)
  #define OF_STDOUT_PATH                "/soc@01c00000/serial@01c28400:115200"
  #endif
  #elif CONFIG_CONS_INDEX == 2 && defined(CONFIG_MACH_SUN5I)
  #define OF_STDOUT_PATH                "/soc@01c00000/serial@01c28400:115200"
index 41039796a02db0c6c0eb9aa172897a963486ad1e..7a0ff9744317ca43b9c9a8e67e2770eca0738f8d 100644 (file)
@@ -6,7 +6,7 @@ Subject: ARM: sunxi: Make CONS_INDEX configurable
 
 --- a/arch/arm/mach-sunxi/Kconfig
 +++ b/arch/arm/mach-sunxi/Kconfig
 
 --- a/arch/arm/mach-sunxi/Kconfig
 +++ b/arch/arm/mach-sunxi/Kconfig
-@@ -412,6 +412,14 @@ config SYS_BOARD
+@@ -416,6 +416,14 @@ config SYS_BOARD
  config SYS_SOC
        default "sunxi"
  
  config SYS_SOC
        default "sunxi"
  
index 309bf704f57bfc72378e15022971fbe6680357a3..aeee5b49759abf2f85d738cabebb54030b1f3eef 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: Antony Antony <antony@phenome.org>
 
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
 
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
-@@ -329,6 +329,7 @@ dtb-$(CONFIG_MACH_SUN8I_V3S) += \
+@@ -337,6 +337,7 @@ dtb-$(CONFIG_MACH_SUN8I_V3S) += \
        sun8i-v3s-licheepi-zero.dtb
  dtb-$(CONFIG_MACH_SUN50I_H5) += \
        sun50i-h5-nanopi-neo2.dtb \
        sun8i-v3s-licheepi-zero.dtb
  dtb-$(CONFIG_MACH_SUN50I_H5) += \
        sun50i-h5-nanopi-neo2.dtb \
index af459823eee8bccef6fc9cf871736b97f72b21fc..1181a44e8088bac3b68d879fc28558fd77152e82 100644 (file)
@@ -18,9 +18,9 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
 
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
-@@ -310,6 +310,7 @@ dtb-$(CONFIG_MACH_SUN8I_A83T) += \
-       sun8i-a83t-cubietruck-plus.dtb \
-       sun8i-a83t-sinovoip-bpi-m3.dtb
+@@ -318,6 +318,7 @@ dtb-$(CONFIG_MACH_SUN8I_A83T) += \
+       sun8i-a83t-bananapi-m3.dtb \
+       sun8i-a83t-cubietruck-plus.dtb
  dtb-$(CONFIG_MACH_SUN8I_H3) += \
 +      sun8i-h2-plus-orangepi-r1.dtb \
        sun8i-h2-plus-orangepi-zero.dtb \
  dtb-$(CONFIG_MACH_SUN8I_H3) += \
 +      sun8i-h2-plus-orangepi-r1.dtb \
        sun8i-h2-plus-orangepi-zero.dtb \
@@ -122,7 +122,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 +};
 --- a/board/sunxi/MAINTAINERS
 +++ b/board/sunxi/MAINTAINERS
 +};
 --- a/board/sunxi/MAINTAINERS
 +++ b/board/sunxi/MAINTAINERS
-@@ -302,6 +302,11 @@ M:        Jagan Teki <jagan@amarulasolutions.co
+@@ -326,6 +326,11 @@ M:        Jagan Teki <jagan@amarulasolutions.co
  S:    Maintained
  F:    configs/orangepi_prime_defconfig
  
  S:    Maintained
  F:    configs/orangepi_prime_defconfig
  
index ca57d585b538b6fdf1513dd9fc952ca6f912b645..4363b5ee2bde6753868c3ec9013dd21d81dc7723 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
 --- a/arch/arm/dts/Makefile
 +++ b/arch/arm/dts/Makefile
-@@ -331,6 +331,7 @@ dtb-$(CONFIG_MACH_SUN8I_V3S) += \
+@@ -339,6 +339,7 @@ dtb-$(CONFIG_MACH_SUN8I_V3S) += \
  dtb-$(CONFIG_MACH_SUN50I_H5) += \
        sun50i-h5-nanopi-neo2.dtb \
        sun50i-h5-nanopi-neo-plus2.dtb \
  dtb-$(CONFIG_MACH_SUN50I_H5) += \
        sun50i-h5-nanopi-neo2.dtb \
        sun50i-h5-nanopi-neo-plus2.dtb \