kernel: fix kmod-ieee802154_6lowpan config symbol
authorJonas Gorski <jogo@openwrt.org>
Fri, 10 Apr 2015 10:30:00 +0000 (10:30 +0000)
committerJonas Gorski <jogo@openwrt.org>
Fri, 10 Apr 2015 10:30:00 +0000 (10:30 +0000)
Fixes build failure caught by buildbot:

IEEE Std 802.15.4 Low-Rate Wireless Personal Area Networks support (IEEE802154) [M/n/y/?] m
  6lowpan support over IEEE 802.15.4 (IEEE802154_6LOWPAN) [N/m/?] (NEW) aborted!

Console input/output is redirected. Run 'make oldconfig' to update configuration.

make[6]: *** [silentoldconfig] Error 1
make[5]: *** [silentoldconfig] Error 2

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 45357

package/kernel/linux/modules/wpan.mk

index b0adda1baee480d16add0722d8e9ea0e34d10d0e..40abfcac6e7a011792daf3caeb821af6409cc0d0 100644 (file)
@@ -109,7 +109,7 @@ define KernelPackage/ieee802154_6lowpan
   SUBMENU:=$(WPAN_MENU)
   TITLE:= 6LoWPAN support over IEEE-802.15.4
   DEPENDS:=@!LINUX_4.0
-  KCONFIG:=IEEE802154_6LOWPAN
+  KCONFIG:=CONFIG_IEEE802154_6LOWPAN
   DEPENDS:=@!LINUX_4.0
   FILES:=$(LINUX_DIR)/net/ieee802154/6lowpan/ieee802154_6lowpan.ko
   AUTOLOAD:=$(call AutoLoad,91,ieee802154_6lowpan)