image.mk: make ubinize.cfg optional
authorFelix Fietkau <nbd@openwrt.org>
Sat, 27 Dec 2014 13:03:19 +0000 (13:03 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 27 Dec 2014 13:03:19 +0000 (13:03 +0000)
When using UbinizeImage with ubifs rootfs, ubinize.cfg is no longer
needed. Yet, the absance of ubinize.cfg would make the build process
abort with an error.
Fix that by checking if ubinize.cfg is present and do no not call the
"classic" ubinize image generation if it isn't.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
[missing new-line before UbinizeImage added itentionally]

SVN-Revision: 43788

include/image.mk

index d6c8b7af87a3ca0a19b30e0c36878c0aca3320c5..7375bf563f6bc6666cdd086097afb058ac2bd2f4 100644 (file)
@@ -146,6 +146,7 @@ ifneq ($(CONFIG_NAND_SUPPORT),)
        (cd "$(KDIR_TMP)"; $(TAR) cvf \
                "$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(2)-sysupgrade.tar" sysupgrade-$(1))
    endef
+
 # $(1) board name
 # $(2) ubinize-image options (e.g. --uboot-env and/or --kernel kernelimage)
 # $(3) rootfstype (e.g. squashfs or ubifs)
@@ -193,10 +194,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
        $(call Image/Build,ubifs)
 
         ifneq ($($(PROFILE)_UBI_OPTS)$(UBI_OPTS),)
-               $(call Image/mkfs/ubifs/generate,)
+               $(if $(wildcard ./ubinize.cfg),$(call Image/mkfs/ubifs/generate,))
                $(if $(wildcard ./ubinize-overlay.cfg),$(call Image/mkfs/ubifs/generate,-overlay))
         endif
-       $(call Image/Build,ubi)
+       $(if $(wildcard ./ubinize.cfg),$(call Image/Build,ubi))
     endef
 endif