uboot-at91: fix DTC command not found.
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Fri, 4 May 2018 17:27:49 +0000 (10:27 -0700)
committerJohn Crispin <john@phrozen.org>
Sat, 5 May 2018 04:55:22 +0000 (06:55 +0200)
fixed DTC command not found error while compling uboot-at91. The fix
is to set DTC PATH in uboot-at91 MAKE command.

Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
package/boot/uboot-at91/Makefile

index 994201e9128d914e3e7af96fd2dec7ffa569f875..b8c6c6e965d1eda07b601982aebf9da6393196ef 100644 (file)
@@ -16,6 +16,7 @@ PKG_SOURCE_VERSION:=59f202622154f82e708a6ca2bf86350a5c1b2d33
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 define U-Boot/Default
   BUILD_TARGET:=at91
@@ -107,6 +108,7 @@ UBOOT_TARGETS := \
 define Build/Compile
   +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
      CROSS_COMPILE=$(TARGET_CROSS) \
+        DTC=$(LINUX_DIR)/scripts/dtc/dtc \
      KCFLAGS="$(filter-out -fstack-protector \
       -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft"
 endef